Opened 17 years ago

Closed 17 years ago

Last modified 11 years ago

#1524 closed defect (invalid)

SAM: Stuttering speech (Also DOTT)

Reported by: SF/teeboy Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

ScummVM version = 0.6.0.0 & 0.5.1.0

Description = Using Sam&Max & DOTT CD versions.
Speech is stuttering constantly.

Language of game = English

Version of game = Talkie CD

Platform and Compiler = Win32 WinXP

Ticket imported from: #913719. Ticket imported from: bugs/1524.

Change History (12)

comment:1 by eriktorbjorn, 17 years ago

Is this with the original monster.sou, or is it MP3- or Ogg Vorbis encoded, i.e. monster.so3 or monster.sog? I can't reproduce the problem on Windows XP - or Linux - with an MP3-encoded file, but I don't have the original monster.sou on this computer to test with.

Other possibilities would probably include flaky sound drivers, or maybe some other program has gone haywire and is hogging all available CPU time. (You can use the task manager to look for the latter.)

comment:2 by SF/teeboy, 17 years ago

This is with the original Monster.sou. I'll try MP3 encoding it and see if it helps any.

comment:3 by fingolfin, 17 years ago

Are you playing from HD or from CD?

comment:4 by fingolfin, 17 years ago

Summary: Stuttering speech (Also DOTT)SAM: Stuttering speech (Also DOTT)

comment:5 by SF/teeboy, 17 years ago

Tried both with DOTT, from CD first, then copied CD to HD and tried again, same problems both times. Only tried Sam&Max from CD.

comment:6 by SF/teeboy, 17 years ago

Just tried SamnMax with an MP3 encoded monster.so3, and I'm getting the same thing. I'll have a look for other sound drivers.

comment:7 by fingolfin, 17 years ago

What kind of machine do you have? I.e. which processor, how fast, how many MB ram, what kind of sound system?

comment:8 by SF/teeboy, 17 years ago

AMD Athlon 1700+ processor, ASUS A7V266 M/b with C- Media onboard sound, 512Mb DDR RAM.

All drivers up-to-date and seem to be working properly otherwise....very strange.

comment:9 by fingolfin, 17 years ago

To quote fds from IRC, after asking about input on this bug:

1:44:<fds> I did try scummvm a bit on a machine with winxp and cmedia onboard audio, worked fine there, although that was a p4 1:48:<fds> the usual response for sound problems on windows with any game is to as the user to play around with the sound acceleration settings in dxdiag.exe

comment:10 by SF/teeboy, 17 years ago

Status: newclosed

comment:11 by SF/teeboy, 17 years ago

Sorted. Changed "No Acceleration" to "Basic Acceleration" and it all works fine. Many Thanks.

I wish someone could sort out Sam & Max 2 as easily.

comment:12 by Kirben, 11 years ago

Owner: set to Kirben
Resolution: invalid
Note: See TracTickets for help on using tickets.