Opened 16 years ago

Closed 15 years ago

#1523 closed defect (fixed)

DIG: Small graphic glitch in front of the Odd Projections

Reported by: SF/gjasny Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

ScummVM 0.5.7cvs (Mar 7 2004 18:35:38)
Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2

The Dig, English, Linux, SDL Backend, GCC 3.3

-Gregor

Ticket imported from: #913334. Ticket imported from: bugs/1523.

Attachments (2)

dig-graphic1.png (55.6 KB ) - added by SF/gjasny 16 years ago.
File showing the glitch
pre-glitch.jpg (37.2 KB ) - added by fingolfin 15 years ago.
Before glitch; the spot marked by the cursor triggers it

Download all attachments as: .zip

Change History (15)

comment:1 by eriktorbjorn, 16 years ago

You will, eventually, describe the glitch, right?

comment:2 by eriktorbjorn, 16 years ago

Summary: DIG: Small graphic glitch in front of the "Odd Projections"DIG: Small graphic glitch in front of the

comment:3 by SF/gjasny, 16 years ago

Sorry for submitting so late ...

by SF/gjasny, 16 years ago

Attachment: dig-graphic1.png added

File showing the glitch

comment:4 by SF/gjasny, 16 years ago

Summary: DIG: Small graphic glitch in front of theDIG: Small graphic glitch in front of the Odd Projections

comment:5 by fingolfin, 16 years ago

Can't reproduce the problem here. Please
* attach a save game near the problematic spot
* describe how to reproduce it (as precise as possible).

comment:6 by eriktorbjorn, 16 years ago

I used to see glitches like that in that room, but I never
figured out exactly how to trigger them. But it's been a
long time since I played The Dig now...

comment:7 by fingolfin, 15 years ago

Yeah, I have seen that glitch in the past, too, but it's been a long time
since then (and in fact, IIRC I closed the original bug report as 'fixed')...

gjasny, any specific hints as to how to reproduce the problem?

comment:8 by fingolfin, 15 years ago

Managed to reproduce this problem (two different instances of it,
actually). First I clicked on the left-most "odd projection". From there,
move to a bit to the right and down; and/or from the right down, move
back to the left most projection. With some "practice" I regularly can
reproduce the glitch now.

by fingolfin, 15 years ago

Attachment: pre-glitch.jpg added

Before glitch; the spot marked by the cursor triggers it

comment:9 by fingolfin, 15 years ago

In the attached screenshot, Low is at the leftmost odd projection. Now
click at the spot where the cursor is in the screenshot. This will trigger
the glitch.

comment:10 by Kirben, 15 years ago

Isn't this issue just due to lack of smooth scrolling in later
games ?

I see similar glitches in Full Thorttle during demo-derby and in
COMI during ship battles.

comment:11 by fingolfin, 15 years ago

Uhm? I see no relation to smooth scrolling at all:
* no horizontal scrolling takes place in this scene at all
* in fact the glitch occurs w/o any scrolling taking place
* if at all, you can scroll vertically in that room, and that has always
been "smooth".

It rather looks like an issue with the akos rendere, and/or with vertical
scrolling.

comment:12 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:13 by fingolfin, 15 years ago

I have no idea why, but it seems this bug is gone now. At least I can not
reproduce the glitch anymore with the technique I described below, while
I can still easily reproduce it with 0.6.1...

Begone, bane of my lif^H^H^Hengine :-)

Note: See TracTickets for help on using tickets.