Opened 15 years ago

Closed 15 years ago

#1516 closed defect (fixed)

COMI: Lines concatenated during songs...

Reported by: SF/donaciano11 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

While trying out for barbershop quartet in act 1.

ie:

Once my old man spoke to good King Trinton [] And asked, 'Why
all this senseless fightin'?'[]`Why can't we men express emotion?
`'[]And now I've got a friend in...

Also during Plunder on my mind, but not the John Silver song and
'Wooden Leg, Restless heart'. Haven't checked the rest.

-Don.

Ticket imported from: #910216. Ticket imported from: bugs/1516.

Attachments (2)

comi.s06 (54.5 KB) - added by SF/donaciano11 15 years ago.
Try out for barbershop quartet, sing plunder on my mind.
comi.2.s06 (54.5 KB) - added by SF/donaciano11 15 years ago.
Try out for barbershop quartet, sing plunder on my mind.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 15 years ago by Kirben

Summary: Lines concatonated during songs...COMI: Lines concatonated during songs...

comment:2 Changed 15 years ago by fingolfin

Summary: COMI: Lines concatonated during songs...COMI: Lines concatenated during songs...

comment:3 Changed 15 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:4 Changed 15 years ago by SF/donaciano11

OS X Panther running daily cvs build to avoid SDL version problems...

Since 0.6.0 (maybe before also) until today April 3rd it still exists. Now
however it seems somebody tried to fix it... when singing the Plunder
Plunder song the old bug of multi-lines posted at once happens at the
middle of the screen and at the top the corrected one line at a time song
plays while the complete text stays in the middle. (Each line printed
twice)

English Talkie with subtitles. Playing from HD not CD.

Changed 15 years ago by SF/donaciano11

Attachment: comi.s06 added

Try out for barbershop quartet, sing plunder on my mind.

Changed 15 years ago by SF/donaciano11

Attachment: comi.2.s06 added

Try out for barbershop quartet, sing plunder on my mind.

comment:5 Changed 15 years ago by SF/donaciano11

OS X Panther running daily cvs build to avoid SDL version problems...

Since 0.6.0 (maybe before also) until today April 3rd it still exists. Now
however it seems somebody tried to fix it... when singing the Plunder
Plunder song the old bug of multi-lines posted at once happens at the
middle of the screen and at the top the corrected one line at a time song
plays while the complete text stays in the middle. (Each line printed
twice)

English Talkie with subtitles. Playing from HD not CD.

comment:6 Changed 15 years ago by fingolfin

AFAIK nobody tried to "fix" this, but it's very well possible that one of the
many other changes made recently has an affect on this issue.

Anyway, this might be related to bug #915585

comment:7 Changed 15 years ago by fingolfin

The "rectangles" you are seeing are the character 0x0b (in hex notation),
see also bug #864030.

I can suppress those, but I would prefer to fix them "properly". If
anybody could provide me with a screenshot of how this looks in the
original... (i.e. with the original LucasArts engine, not with ScummVM)...

comment:8 Changed 15 years ago by Kirben

The problem only occurs in ScummVM when both speech and
subtitles are enabled (VAR_VOICE_MODE = 1), using one or
the other works fine.
The original COMI (English version) never shows the complete
song at all.

Maybe this is due to a room script (room-21-2021) changing
the VAR_VOICE_MODE value ? maybe we should be checking
its value in code, like original game ? I think this is only place
where VAR_VOICE_MODE is changed by scripts.

Part of room-21-2021) room script:
[78B0] (65) if (VAR_VOICE_MODE == 2) {
[78C0] (91) talkActor("/VDGT404T/Oh, there's a monkey in
my pocket,",1)
[78F3] (69) wait.waitForMessage()
[78F5] (91) talkActor("/VDGT405T/And he's stealing all my
change",1)
[7925] (69) wait.waitForMessage()
[7927] (91) talkActor("/VDGT406T/His stare is blank and
glassy,",1)
[7956] (69) wait.waitForMessage()
[7958] (91) talkActor("/VDGT407T/I suspect that he's
deranged....",1)
[7989] (69) wait.waitForMessage()
[798B] (65) } else if (VAR_VOICE_MODE == 0) {
[79A0] (91) talkActor("/VDGT404/Oh, there's a monkey in
my pocket,",1)
[79D2] (69) wait.waitForMessage()
[79D4] (66) } else {
[79D9] (6D) VAR_VOICE_MODE = 0
[79E3] (91) talkActor("/VDGT404/Oh, there's a monkey in
my pocket,",1)
[7A15] (6D) var208 = 42
[7A1F] (65) while (((var208 >= 0) && VAR_HAVE_MSG) &&
(VAR_TALK_ACTOR == 1)) {
[7A41] (97) blastText.baseop()
[7A43] (97) blastText.wrap()
[7A45] (97) blastText.charset(1)
[7A4C] (97) blastText.color(15)
[7A53] (97) blastText.center()
[7A55] (97) blastText.XY(getObjectX(1),(getObjectY(1) -
300))
[7A69] (97) blastText.msg("/VDGT404T/Oh, there's a
monkey in my pocket,")
[7A98] (67) breakHere()
[7A99] (6D) var208 = (var208 - 1)
[7AA9] (65) if (!VAR_HAVE_MSG) {
[7AB4] (6D) var208 = -1
[7ABE] (**) }
[7AC3] (**) }

comment:9 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.