Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1515 closed defect (fixed)

COMI: overlapping speech in Act III pirate song

Reported by: SF/mmebane Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Windows XP; March 04 Win32 Daily Build
ScummVM 0.6.0pre (Mar 4 2004 19:52:54)

In the pirate song at the beginning of Act III,
sometimes you can hear bits of one piece of speech
overlapping with another. I can't figure out exactly
why, but I've found a way to reproduce it 100%.

With the attached save, choose

"Let's go defeat that evil pirate!"

then

"No time for song! We've got to move!"

The pirates will respond by singing

"The battle will be long,
but our courage we will prove"

While they are singing this, in the background you can
hear "roam the sea".

There are also a few other points in the game where the
sppech overlaps like this, but I don't have saves for
them right now.

Ticket imported from: #910007. Ticket imported from: bugs/1515.

Attachments (1)

comi.s35 (56.0 KB) - added by SF/mmebane 15 years ago.
Save @ Act III Pirate Song

Download all attachments as: .zip

Change History (8)

Changed 15 years ago by SF/mmebane

Attachment: comi.s35 added

Save @ Act III Pirate Song

comment:1 Changed 15 years ago by SF/mmebane

Oh, yeah... English version of CoMI

comment:2 Changed 15 years ago by Kirben

Owner: set to aquadran

comment:3 Changed 15 years ago by eriktorbjorn

When I tried this (using boot params to get to the scene - I
still haven't played CMI that far in ScummVM), I also got
overlaps in the song. Seemed to be because the old music
took an awfully long time (15 seconds or more) to fade out
when the next verse started.

comment:4 Changed 15 years ago by aquadran

what is current status with latest cvs version ?

comment:5 Changed 15 years ago by Kirben

I'm unable to reproduce the problem under Windows now, the
pirate song seems perfect :)

comment:6 Changed 15 years ago by aquadran

Status: newclosed

comment:7 Changed 15 years ago by aquadran

Resolution: fixed
Note: See TracTickets for help on using tickets.