Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1503 closed defect (fixed)

COMI: Text draw problem in first dialogue with Murray (2)

Reported by: SF/bigmuzzy Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

[There was report about this problem, but it's status is
Closed. I've also reported this in 777999]

(Subtitles set to ON). When Guybrush squeezes through
cannon window and talks to Murray, he can choose
line "You know, you'd look great with a melting candle
on your forehead". This phrase appears partly
transparent (in the middle) and so do the part of
Guybrush body behind it. More than that, rest of the
text doesn't vanish and new subtitles appear right
above it.

I'm attaching savegame with Guybrush is ready to say
this line. And, if you can't reproduce this bug, I'll attach
screensave later.

[English version of CoMI; Windows XP SP1; ScummVM
0.6.0pre (Feb 27 2004 14:30:13)]

Ticket imported from: #905856. Ticket imported from: bugs/1503.

Attachments (2)

comi.s07 (49.6 KB ) - added by SF/bigmuzzy 16 years ago.
Guybrush is ready to talk to Murray
comi01.jpg (37.7 KB ) - added by SF/bigmuzzy 16 years ago.
Text draw problem

Download all attachments as: .zip

Change History (4)

by SF/bigmuzzy, 16 years ago

Attachment: comi.s07 added

Guybrush is ready to talk to Murray

by SF/bigmuzzy, 16 years ago

Attachment: comi01.jpg added

Text draw problem

comment:1 by fingolfin, 16 years ago

Fixed in CVS. The problem was caused by text being position at x
coordinate 0; this was then changed to coordinate -1 by the NUT
renderer, which is a special valued used in other parts of the code as a
flag... booom.

comment:2 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.