Opened 15 years ago

Closed 15 years ago

#1494 closed defect (invalid)

FOA: Cannot start game

Reported by: SF/siminka Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Hi all,

I'm using scummvm 0.5.1 with libSDL 1.2.7

MI, MI2, INDYVGA runs without problems. But when
launching Indy4 I get this error:

Looking for atlantis
Trying to start game 'Indiana Jones and the Fate of
Atlantis'
(0:0:0x0): charset 1 not in room 68 at 6981281+73953 in
file atlantis.001!
(0:0:0x0): charset 1 not in room 68 at 6981281+73953 in
file atlantis.001

There's a patch from Lucasarts that seems to be able to
fix that...but I have no windows/dos machine to install.

I'm using the german version - here are the md5sums (if
someone wants to compare his version):

0cc517e86b64feb4cdbd692c142a1d6f adlib.ims
1fbebd7b2b692df5297870447a80cfed atlantis.000
f5d2aa185b5c2524761d2b5670d599d0 atlantis.001
317589c0b24b5178c079a49a52c7ed37 atlantis.exe
8b4e29b7234795e5e16da088d7271e31 roland.ims
0cc517e86b64feb4cdbd692c142a1d6f sounblas.ims
5d6d1ec34f9c4cf0fa77d04890317175 speaker.ims

Bye,
Oliver

Ticket imported from: #903296. Ticket imported from: bugs/1494.

Change History (8)

comment:1 Changed 15 years ago by fingolfin

Summary: Cannot start Indy4FOA: Cannot start game

comment:2 Changed 15 years ago by fingolfin

The bug submission form mentions three things you should do when filing
a bug report :-). To quote it:

"Secondly, try out the latest CVS/daily build"

Please do that, and then tell us if you still have the problems. If you do,
please read the rest of the bug submission form and follow the remaining
advices there. Thanks!

comment:3 Changed 15 years ago by SF/siminka

Tried the current 0.5.7 CVS version - same problem.

Here are the other requested information:

- Bug details, including instructions on reproducing
...just try to start the game

- Version of game (talkie, floppy, ...)
...floppy

- Platform and Compiler (Win32, Linux, FreeBSD, ...)
...Linux 2.6.3 x86

comment:4 Changed 15 years ago by fingolfin

Resolution: worksforme

comment:5 Changed 15 years ago by fingolfin

The checksum of your main data file doesn't match any of mine. In
particular, the MD5 of your ATLANTIS.000 is that of a german floppy
version (you didn't tell us the language of your data files, BTW), but the
.001 file doesn't match any of the other data files. Hence it's most
probably corrupt.

For reference: File size of the corresponding ATLANTIS.001 should be:
9711182 bytes, MD5 sum 138dd237fb46bb3f4c7659161d10abf7

comment:6 Changed 15 years ago by SF/siminka

...sure I told which language I'm running (see my initial
posting). But you're right - my atlantis.001 is not the
orignial one. I used the patched installer from the
lucasarts website (which seems to modify the atlantis.001
file). I installed the game with the original installer and
now it runs flawlessly, so you can close this bogus bug :-)

BTW: It seems to be impossible to change the global
graphics-mode in the current CVS version.

comment:7 Changed 15 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksformeinvalid
Status: newclosed

comment:8 Changed 15 years ago by fingolfin

Sorry I overlooked the reference to the game language.

"BTW: It seems to be impossible to change the global
graphics-mode in the current CVS version."
-> I don't see what you mean... switching the graphics modes via
keyboard works just fine. If you meant something else, file a bug report,
but please explain what precisely you mean -- sadly, those mind reader
modules (telepath add-on) are still far too expensive for me to afford
them :-)

Note: See TracTickets for help on using tickets.