Opened 16 years ago

Closed 15 years ago

#1493 closed defect (fixed)

COMI: Guybrush reads church clock incorrectly (German)

Reported by: SF/simonbrueckner Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

When looking at the church clock of porto pollo, Guybrush reads
the time in international versions of the game (or at least in the
english one).
In the german version, this feature has been disabled because of
the bad grammar ...
But it seems as it had been recorded because in the emulation,
Guybrush reads it like intended by the game writers.

But in the original german PC version, Guybrush only says "So spät
schon? Ich muss los!" (This late? Gotta go!)

Ticket imported from: #903223. Ticket imported from: bugs/1493.

Change History (12)

comment:1 by SF/khalek, 16 years ago

are you specifying a language when running the game?

comment:2 by fingolfin, 16 years ago

Pending reply by bug submitter.

comment:3 by fingolfin, 16 years ago

Status: newpending
Summary: Guybrush reads church clock incorrectly in German version.COMI: Guybrush reads church clock incorrectly (German)

comment:4 by SF/simonbrueckner, 16 years ago

I specified "german" as language!

comment:5 by SF/simonbrueckner, 16 years ago

Status: pendingnew

comment:6 by fingolfin, 16 years ago

I can reproduce the problem.

Looking at the script, I see nothing which would turn it off for e.g. the
german version.
Maybe there is a hack in the german version of the engine to specifically
disable that script. Hard to tell (and maybe I just overlooked something
when checking the scripts).

comment:7 by SF/simonbrueckner, 16 years ago

I also assume this is a quick and dirty hack that was made to the german
version shortly before sales started after quality assurance saw the low
quality of the spoken time.
I could imagine this is not a scummvm thing but really hard coded
somewhere.
Nevertheless i will use the resource extractor to find the sample that is
used there. Perhaps that helps!

comment:8 by fingolfin, 15 years ago

Simon, what exactly does Guybrush say? The text you posted? Or maybe
"Boah! Schon so spt. Ich mu gehen." ?

comment:9 by SF/simonbrueckner, 15 years ago

Hello fingolfin,

I think you are right! Your posted text is the correct one!
I have to admit i recalled it from memory because i have no PC handy.
Just a Mac where it won't run without ScummVM ...

But thanks for still looking into this problem!

Greets from Darmstadt ;-)

Simon

comment:10 by fingolfin, 15 years ago

if the text is correct, then I can probably add a hack into ScummVM to
emulate this behaviour.

So you are from Darmstadt, too? Funny :-)

comment:11 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:12 by fingolfin, 15 years ago

I added a workaround to CVS.

Note: See TracTickets for help on using tickets.