Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1471 closed defect (fixed)

DIG: Missing Subtitles when talking to Miles

Reported by: SF/trinity78 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Using:

Win2k - Sp4
ScummVM 0.60pre (feb 19 2004)
The Dig - english

Bug:

After the intro, when using the PenUltimate to talk with
Miles, some sentences are missing.
In the original, if you click on the head of Miles following
dialog appears:

Boston: Miles this is Low, do you read.
Miles: Yeah, Yeah, Boston I'm on you.
Miles and Boston: You wish.
Miles and Boston: In your dreams.

Using ScummVM only the first two lines appear:

Boston: Miles this is Low, do you read.
Miles: Yeah, Yeah, Boston I'm on you.

The speech and the subtitles for the other two
sentences are missing, but the animation of Miles mouth
is shown.

No savegeame attached, because it is the first scene in
the game.

Ticket imported from: #900359. Ticket imported from: bugs/1471.

Change History (13)

comment:1 Changed 15 years ago by eriktorbjorn

This is a regression - it used to work fine. (I haven't even
tried to figure out why it's broken now though.)

comment:2 Changed 15 years ago by fingolfin

Summary: [DIG] Missing SpeechDIG: Missing Speech

comment:3 Changed 15 years ago by fingolfin

Priority: normalhigh
Summary: DIG: Missing SpeechDIG: Missing Speech (regression, 0.6.0)

comment:4 Changed 15 years ago by eriktorbjorn

Here's a fragment from script-252. I don't yet know what's
wrong, though.

[00FC] (BA) talkActor("/NEWTON.031/Yeah yeah yeah, Boston.
I'm on you.",13)
[0132] (A9) wait.waitForMessage()
[0134] (B8) printActor.begin(13)
[0139] (B8) printActor.new3()
[013B] (B8) printActor.msg("/NEWTON.032/")
[014A] (82) animateActor(13,6)
[0151] (5D) if (!(VAR_VOICE_MODE == 0)) {
[015C] (5D) while (VAR_TALK_ACTOR == 13) {
[0166] (A4) arrayOps.arrayOps205("You wish.",0,130)
[0177] (C9) kernelSetFunctions.enqueueTextA([2,9,160,20])
[018A] (A4) arrayOps.arrayOps205("You wish.",0,130)
[019B] (C9) kernelSetFunctions.enqueueTextA([2,11,160,50])
[01AE] (6C) break()
[01B2] (**) }
[01B2] (**) }
[01AF] (A9) wait.waitForMessage()
[01B4] (82) animateActor(13,7)
[01BB] (B8) printActor.begin(13)
[01C0] (B8) printActor.new3()
[01C2] (B8) printActor.msg("/NEWTON.034/")
[01D1] (82) animateActor(13,6)
[01D8] (5D) if (!(VAR_VOICE_MODE == 0)) {
[01E3] (5D) while (VAR_TALK_ACTOR == 13) {
[01ED] (A4) arrayOps.arrayOps205("In your dreams.",0,130)
[0204] (C9) kernelSetFunctions.enqueueTextA([2,9,160,20])
[0217] (A4) arrayOps.arrayOps205("In your dreams.",0,130)
[022E] (C9) kernelSetFunctions.enqueueTextA([2,11,160,50])
[0241] (6C) break()
[0245] (**) }
[0245] (**) }
[0242] (A9) wait.waitForMessage()
[0247] (82) animateActor(13,7)

comment:5 Changed 15 years ago by Kirben

Owner: set to fingolfin

comment:6 Changed 15 years ago by Kirben

The missing speech is caused by scumm/string.cpp revision
1.186. Specially the hack added to distinguish between 'real'
actor speech and other strings.

comment:7 Changed 15 years ago by Kirben

I restricted that hack to COMI for now, as I don't think it is
needed for the DIG at all.

I enabled support for VAR_VOICE_MODE too but those
subtitles still aren't showing up for some reason...

comment:8 Changed 15 years ago by eriktorbjorn

The subtitles for those two lines didn't show up in 0.5.1
either. I just checked.

comment:9 Changed 15 years ago by Kirben

Owner: fingolfin deleted
Priority: highnormal
Summary: DIG: Missing Speech (regression, 0.6.0)DIG: Missing Subtitles

comment:10 Changed 15 years ago by Kirben

Summary: DIG: Missing SubtitlesDIG: Missing Subtitles when talking to Miles

comment:11 Changed 15 years ago by Kirben

The subtites are now shown, fingolfin's last translation
changes fixed it.

comment:12 Changed 15 years ago by Kirben

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:13 Changed 15 years ago by fingolfin

Cool :-) I love "free" bug fixes :-)

Note: See TracTickets for help on using tickets.