Opened 16 years ago

Closed 16 years ago

#1470 closed defect (invalid)

INDY3 Spanish: Can't get officer uniform

Reported by: SF/calvaris Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

I'm using the 0.5.1 version with indy3 PC VGA
spanish version in Linux. I tried it with the CVS compiled
version (20040218) and the problem occurs too.

I get the problem when trying to get the officer
uniform using the key (In spanish the object is called
"llave"):

(27:407:0x43C2): Value 8293 is out of bounds (0,999)
(Object 8293 out of range in getOwner)!

I can't play :'(((

Ticket imported from: #899996. Ticket imported from: bugs/1470.

Attachments (1)

indy3.s06 (56.0 KB ) - added by SF/calvaris 16 years ago.
It is the savegame

Download all attachments as: .zip

Change History (9)

by SF/calvaris, 16 years ago

Attachment: indy3.s06 added

It is the savegame

comment:1 by SF/khalek, 16 years ago

Can't reproduce this here using an english version with the
save.

comment:2 by SF/khalek, 16 years ago

Keywords: script removed
Summary: It fails when getting the officer uniform inside the castleINDY3: Can't get officer uniform

comment:3 by fingolfin, 16 years ago

Using a savegame with a different-language game data file set isn't a
good way to test anything, though :-)

comment:4 by SF/ender, 16 years ago

Summary: INDY3: Can't get officer uniformINDY3 Spanish: Can't get officer uniform

comment:5 by SF/ender, 16 years ago

This has not been confirmed by any other other people
playtesters for this title.

If it exists, it's possibly only related to the Spanish version - which
I do not believe any of the developers own. In fact, I don't think
we have any spanish devs. Unusual that, actually :)

comment:6 by SF/kelmer, 16 years ago

This bug should be removed, as there was never a spanish
version of Indy3 VGA.

There is indeed an unofficial translation (made by me and a
friend), which is just a plain text modification of the english
version, so, technically, it should give no problems with
scummvm.

If I remember correctly, we only changed the text lines of
each .lfl file, plus the file containing those sprites from the
characters shown in screen (that is, "a", "b", "c", and so on).
So basically it's just the english version.

However, the error indeed occurs.

Yet, if you are willing to support this unofficial translation as
well, I encourage you to try it (I can provide you with the
files necessary).

On the other hand, I offer myself to try whatever game in
spanish which would give any language-related problems.

comment:7 by SF/ender, 16 years ago

Owner: set to SF/ender
Resolution: invalid
Status: newclosed

comment:8 by SF/ender, 16 years ago

Thanks for letting us know, Kelmer. Okay, I'm closing this then as
we certainly do not support unofficial translations.

It's still an odd bug, but I assume it's because the translation is a
little glitched somewhere (maybe a string isn't terminated
correctly, or overwrites an opcode somewhere).

Note: See TracTickets for help on using tickets.