Opened 17 years ago

Closed 17 years ago

Last modified 10 years ago

#145 closed defect (fixed)

Indy4: ballon ride

Reported by: SF/inguin Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Indiana Jones 4

Description

I'm stuck during the Indy4 (german) ballon ride: I found the "X" on the map, but as I tried to land on that place the ballon started to wobble and I'm not able to control it any longer. I attached a savegame of that situation.

Ticket imported from: #541506. Ticket imported from: bugs/145.

Attachments (2)

atlantis.s01 (46.8 KB) - added by SF/inguin 17 years ago.
indy4 ballon ride savegame
atlantis.s05 (45.9 KB) - added by SF/inguin 17 years ago.
immediately BEFORE the bug

Download all attachments as: .zip

Change History (11)

Changed 17 years ago by SF/inguin

Attachment: atlantis.s01 added

indy4 ballon ride savegame

comment:1 Changed 17 years ago by SF/mutle

I tried to load the save game, but you seem to use an
older Version of ScummVM... What Version were you
using?

comment:2 Changed 17 years ago by SF/inguin

It's the latest CVS version, "ScummVM 0.2.0 devel". Maybe we've got different versions of the Indy4 data files, scummvm reports

Detected game 'Indiana Jones 4 and the Fate of Atlantis', version 5.5.0

with mine.

comment:3 Changed 17 years ago by (none)

Logged In: NO

I have the same problem. I'm running the following scummvm:
$ ~/indy4> scummvm
-v
ScummVM 0.2.0 devel
Built on Apr 13 2002 14:23:18

I put a savegame at <http://ifix.cx/atlantis.s05>.

There is also the following errormessage when reaching the
X:
WARNING: stub unkScreenEffect4()!
WARNING: SoundEngine::do_command invalid command 2!
WARNING: SoundEngine::do_command invalid command 3!
WARNING: SoundEngine::do_command invalid command 3!
WARNING: SoundEngine::do_command invalid command 3!
WARNING: SoundEngine::do_command invalid command 3!
WARNING: SoundEngine::do_command invalid command 3!
WARNING: SoundEngine::do_command invalid command 3!
[...]
The last line, with the invalid command 3 repeats all the
time, and I
can't to anything...

Hope the savegame works and you can reproduce the bug. :)

Regards, Daniele

Changed 17 years ago by SF/inguin

Attachment: atlantis.s05 added

immediately BEFORE the bug

comment:4 Changed 17 years ago by SF/inguin

I attached Daniele's savegame to this bug report. It's more suitable than my one, because he saved before he was actually stuck.
Hm, maybe Indy4 depends on the sound engine there and the bug resolves itself as soon as the redesign is finished.

comment:5 Changed 17 years ago by SF/ender

Component: Engine: SCUMM
Game: Indiana Jones 4
Keywords: script added

comment:6 Changed 17 years ago by SF/ender

Changing group/catagory to match new bug guidelines.

This one is getting a bit old, sorry inguin... I'm trying
to find someone else to look into it, as I can never get
past the balloon scene anyway - but or not! :)

comment:7 Changed 17 years ago by SF/ender

Please retest with latest CVS - this should be fixed now.
Closing bug - reopen if problem still exists.

comment:8 Changed 17 years ago by SF/ender

Resolution: fixed
Status: newclosed

comment:9 Changed 10 years ago by Kirben

Owner: set to SF/ender
Note: See TracTickets for help on using tickets.