Opened 18 years ago

Closed 18 years ago

Last modified 12 months ago

#146 closed defect (invalid)

DOTT German Talkie bugs

Reported by: SF/andrej4000 Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

Bugs

Talking (clicking on two-lines-text):
WARNING: CHARSET_1: invalid code 8!

After newspaper appears first time:
Little text drawing error for one or two seconds

Laverne and the bad tentacle:
When Laverne comes in and talks, she looks to the
wall instad of the tentacle.
see "Tentacle.gif"

In the best human contest the tentacles tell a joke,
the screen text joke and the speech joke are not
identical (2 different jokes)

Using hampster in the future:
WARNING: setObjectState: no such object!
WARNING: setObjectState: no such object!

Epilogue:
SoundEngine::findTag failed finding sound 46
SoundEngine::findTag completely failed finding sound 47
SoundEngine::findTag completely failed finding sound 47
WARNING: SE::start_sound failed: Couldn't find MDhd!

Save/Load-Box in German version too small:
see "Tentacle2.gif"

Not real bugs

Rare in the game:
WARNING: SoundEngine::do_command invalid command 2!

Often in the game:
WARNING: SoundEngine::do_command invalid command 3!

Often in the game during Animations:
WARNING: EGA_proc4!

Hoagie (Bernard/Laverne button appearing); Freeing Dr.
Fred:
WARNING: No mixer channel available!

Hoagie (e.g. looking on battery plans):
WARNING: o6_roomops:180: partially unimplemented!

Playing with Ed's Computer (you'll not integrate this
function):
WARNING: stub startManiac()!

Hoagie washing car:
WARNING: stub unkScreenEffect3()!

From time to time:
WARNING: Unknown screen effect, 0

A hack?:
WARNING: o6_animateActor(593,250): fixed tentacle bug!

Ticket imported from: #541625. Ticket imported from: bugs/146.

Attachments (5)

Tentacle.gif (113.3 KB ) - added by SF/andrej4000 18 years ago.
Tentacle2.gif (98.4 KB ) - added by SF/andrej4000 18 years ago.
Tentacle3.gif (95.7 KB ) - added by SF/andrej4000 18 years ago.
Tentacle4.gif (115.0 KB ) - added by SF/andrej4000 18 years ago.
Tentacle5.gif (99.5 KB ) - added by SF/andrej4000 18 years ago.

Download all attachments as: .zip

Change History (11)

by SF/andrej4000, 18 years ago

Attachment: Tentacle.gif added

by SF/andrej4000, 18 years ago

Attachment: Tentacle2.gif added

comment:1 by SF/ender, 18 years ago

Owner: set to SF/ender
Summary: DOTT German Tlkie bugsDOTT German Talkie bugs

comment:2 by SF/ender, 18 years ago

Can you tell me exactly what the effect of these bugs is?

I can understand the joke bug (no idea why, this should be
technically impossible as the line of speach to play is
encoded in the line of text to read - this may actually be
a bug in the translation itself)...

The 'not real bugs' are all known warnings. None of these
matter - that's why they are warnings :)

The save/load box being too small is exactly the same when
played under DOS, from what I was told.

WARNING: CHARSET_1: invalid code 8! <-- Does this warning
actually DO anything bad? Remember, warnings are OK unless
something bad happens after them.

Ditto for the Epilouge and hampster bugs. Do these warnings
actually cause anything to BREAK? If so, what.

What happens with the text after the first newspaper?

Please, describe the bugs, don't just say "oh, there's a
bug here" :)

comment:3 by SF/andrej4000, 18 years ago

There are no real havy bugs and no problems completing the
game...

"WARNING: CHARSET_1: invalid code 8!" isn't real bad...
seems to be just a warning...

newspaper bug: the first text line after reading the first
newspaper appears is not readbale, however all following
text line are displayed properly.

Epilogue and hampster: the gameplay isn't affected in
anyway, perhaps just errors in the original dott-script...

save/load: "Tentacle3.gif" is the DOS screenshot...
also "Tentacle4.gif" (ScummVM) and "Tentacle5.gif" (DOS)
added...
but all save/load bugs are just cosmetic...
(I think it's only in the german DOTT version)

joke bug: I'll try to reproduce this in the ScummVm and DOS
version

by SF/andrej4000, 18 years ago

Attachment: Tentacle3.gif added

by SF/andrej4000, 18 years ago

Attachment: Tentacle4.gif added

by SF/andrej4000, 18 years ago

Attachment: Tentacle5.gif added

comment:4 by SF/ender, 18 years ago

Resolution: invalid
Status: newclosed

comment:5 by SF/ender, 18 years ago

I'm closing this now.. I will look into the newspaper bug,
and if you can reproduce the joke bug please open a new
report.

comment:6 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Day of the Tentacle
Note: See TracTickets for help on using tickets.