Opened 16 years ago

Closed 14 years ago

#1447 closed defect (fixed)

FT: Error when escing smush scene

Reported by: Kirben Owned by: fingolfin
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Latest ScummVM cvs version.
English version of Full Throttle V1

ScummVM often reports the follow error when escing
smush or insane sequences under linux
(13:82:0xD25): invalid index in
SaudChannel::checkParameters

A valgrind log of output just before error is attached.

Ticket imported from: #894249. Ticket imported from: bugs/1447.

Attachments (2)

ft.s14 (7.8 KB ) - added by Kirben 15 years ago.
Fresh saved game
valgrind.txt (5.0 KB ) - added by Kirben 15 years ago.
Valgrind log

Download all attachments as: .zip

Change History (27)

comment:1 by Kirben, 16 years ago

I fixed the valgrind warning but unfortunately it still errors at
that point every time.
I have attached a save game, go back onto Main Road, turn
into Mine Road at first sign and esc when entering Mine Road
sequence is shown.

comment:2 by SF/ender, 16 years ago

Does this still occur?

comment:3 by Kirben, 16 years ago

Priority: highnormal

comment:4 by Kirben, 16 years ago

Yes, I noticed it only occurs when running ScummVM under
valgrind though. So maybe timing related...

comment:5 by aquadran, 15 years ago

i can't reproduce bug

comment:6 by fingolfin, 15 years ago

Priority: normalhigh

comment:7 by fingolfin, 15 years ago

What is the status of this item?

comment:8 by Kirben, 15 years ago

Unchanged, still occurs.

comment:9 by aquadran, 15 years ago

Priority: highnormal

comment:10 by fingolfin, 15 years ago

Owner: changed from aquadran to sev-

comment:11 by fingolfin, 15 years ago

Wondering if sev can reproduce this, since apparently aquadran cannot?

comment:12 by sev-, 15 years ago

Yes, I can't reproduce it here.

comment:13 by fingolfin, 15 years ago

Very strange, then... Kirben, I assume *you* can still reproduce it? If so,
anything more specific regarding how you reproduce it?

comment:14 by Kirben, 15 years ago

I'm unable to check right now, as I don't have access to linux
at the moment.

comment:15 by Kirben, 15 years ago

Owner: sev- removed
Status: newclosed

comment:16 by Kirben, 15 years ago

Status: closednew

comment:17 by Kirben, 15 years ago

The problem still occuring when running ScummVM under
Valgrind, I even tried with boot patam 550, in case the
saved game was bad.

Attached fresh saved game, where I can always reproduce issue:
Run ScummVM under Valgrind, with that saved game.
Exit left side of screen to main road.
Enter mine road at first turning point.
Esc anytime during the 'entering mine road' smush and error
will occur.

by Kirben, 15 years ago

Attachment: ft.s14 added

Fresh saved game

comment:18 by Kirben, 15 years ago

Summary: FT: Error when escing insane or smushFT: Error when escing smush scene

comment:19 by fingolfin, 15 years ago

Priority: normalhigh

comment:20 by fingolfin, 15 years ago

Just FYI, I can't reproduce any problem there on Mac OS X,
using the provided save game.

Maybe you can attach the Valgrind log?

comment:21 by Kirben, 15 years ago

I can still reproduce the error sometimes with latest
ScummVM cvs.

I attached a valgrind log, but it doesn't report anything
useful before the error occurs.

by Kirben, 15 years ago

Attachment: valgrind.txt added

Valgrind log

comment:22 by fingolfin, 15 years ago

This sounds a lot like a race condition, though looking over
the code I see nothing obvious.

Or maybe Eugene's guess is right that somewhere memory is
overwritten (Valgrind can only detect if we overwrite memory
which is not allocated -- it has no way to know whether we
overwrite allocated memory "correctly" or not).

See also bug #933631 and #1087234.

comment:23 by fingolfin, 15 years ago

I just fixed a SMUSH/INSANE race condition (I think), no idea if that will
affect this bug, but if anybody wants to do a retest... :-)

comment:24 by Kirben, 14 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:25 by Kirben, 14 years ago

I can no longer reproduce the issue, so closing.

Note: See TracTickets for help on using tickets.