Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1446 closed defect (worksforme)

Mac mouse does not work

Reported by: SF/pwall5 Owned by: fingolfin
Priority: normal Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

The current CVS does not support the macintosh os x mouse in the
item selection of the full version of Broken Sword 1 or 2, it puts
the normal mac pointer on top of the BS mouse pointer and does
not interact. This happens every time.

I am in Mac OS X 10.3, using the 3.3 apple compiler.

Ticket imported from: #893732. Ticket imported from: bugs/1446.

Change History (5)

comment:1 by fingolfin, 16 years ago

The interesting question here, is, which SDL version do you use? Do you
run in fullscreen? Did you consider updating to 10.3.2 :-)

Anyway, I can't reproduce any such problems over here.

comment:2 by SF/pwall5, 16 years ago

I am using 10.3.2, sorry about that, and I am using SDL version 1.2.6. I
am not in fullscreen, and interestingly enough this error does not occur
in fullscreen with me. Some more specifications include that I am on a
dual 2.0 GHz G5 with an ATI Radeon 9600 Pro. I have tried multiple
resolutions. It is also not only the item part that will not click, but the
lower 1/6 or so of the screen.

comment:3 by SF/khalek, 16 years ago

Try the snapshot linked off the download page its built
using SDL from CVS.

comment:4 by fingolfin, 16 years ago

This is a bug in SDL 1.2.6, and not in ScummVM.

SDL 1.2.7 will be released real soon now.

comment:5 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.