Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1444 closed defect (fixed)

MI1VGA: Changes in object names are not saved

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 1

Description

In pre-V6 games, changes in object names are not saved.
One case where this can be observed is in MonkeyVGA, in
the SCUMM Bar, once you have completed the three tasks.

At this point, the SCUMM Bar is deserted, except for
the cook. His object name is "cook". However, if you
save and then restore that savegame, his object name
will have reverted to "important-looking pirates".
Apparently there is an object doubling for both the
cook and the pirates, and it's the room's entry script
that changes the name of it.

Originally I hadn't intended to report this bug since
the comments in the code indicates that it's known. Or
at least the general principles behind it are.
Therefore I don't have a savegame on this computer that
I can attach. I'll bring one later.

Ticket imported from: #893254. Ticket imported from: bugs/1444.

Change History (6)

comment:1 by fingolfin, 16 years ago

I have a fix locally, by using rtObjectName resources in all Scumm
versions. This simplifies the code a bit, too.

But what confuses me right now is why this bug does *not* occur in
"monkey" (only in monkeyvga, and probably monkeyega, too). The only
difference I notice in o5_setObjectName is that the one is a small header
game, while the newer CD-version isn't. But both seems to directly
modify the object resource... hu?

I am probably overlooking something, which isn't too surprising given
that I have a biig headache and just want to go to bed now =)

comment:2 by fingolfin, 16 years ago

Owner: set to fingolfin

comment:3 by fingolfin, 16 years ago

There is a fix in CVS now, please test.

comment:4 by eriktorbjorn, 16 years ago

I see I completely forgot to bring that savegame I promised,
so I had to cheat a bit with boot params. As far as I can
tell, your patch works. (As for the regressions you warned
about... only time will tell. :-)

comment:5 by fingolfin, 16 years ago

Status: newclosed

comment:6 by fingolfin, 16 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.