Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#1412 closed defect (fixed)

DOTT: Transition effect glitch (regression)

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

I've been playing through Day of the Tentacle with a
recent CVS snapshot.

I noticed a slight glitch that I believe may be a
regression. In the future, after showing one of those
"Meanwhile..." interludes, the screen wasn't completely
cleared. Presumably because virtscreen 0 covered the
entire screen during the interlude, but not afterwards.

That meant that for a brief time the verb/inventory
area of the screen contained garbage.

I'm attacing a saved game. It should be enough to
simply walk into the kitchen or entrance hall (but not
through the chimney or into the kennel?) to trigger the
interlude.

I'm not sure how to fix it, but I did notice that
initVirtScreen() will call setDirtyRange() in most
cases. If I add a call to updateDirtyScreen() as well,
the glitch goes away.

Ticket imported from: #884171. Ticket imported from: bugs/1412.

Attachments (2)

tentacle.s10 (13.3 KB ) - added by eriktorbjorn 16 years ago.
Savegame (compressed) near glitch
gfx.diff (378 bytes ) - added by eriktorbjorn 16 years ago.
Patch against a January 23 CVS snapshot

Download all attachments as: .zip

Change History (10)

by eriktorbjorn, 16 years ago

Attachment: tentacle.s10 added

Savegame (compressed) near glitch

by eriktorbjorn, 16 years ago

Attachment: gfx.diff added

Patch against a January 23 CVS snapshot

comment:1 by eriktorbjorn, 16 years ago

Summary: Transition effect glitch (regression?)DOTT: Transition effect glitch (regression?)

comment:2 by fingolfin, 16 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:3 by eriktorbjorn, 16 years ago

Kirben has confirmed that the patch was wrong, and it was
causing regressions in FOA. See patch #889552 and bug
#893500 for details.

I have reverted the patch which, of course, means that this
bug is once again happening.

comment:4 by eriktorbjorn, 16 years ago

Resolution: fixed
Status: closednew

comment:5 by Kirben, 15 years ago

Summary: DOTT: Transition effect glitch (regression?)DOTT: Transition effect glitch (regression)

comment:6 by Kirben, 15 years ago

Ths is a regression caused by scumm/saveload.cpp revision
1.129.

comment:7 by Kirben, 15 years ago

Status: newclosed

comment:8 by Kirben, 15 years ago

Owner: changed from eriktorbjorn to Kirben
Resolution: fixed
Note: See TracTickets for help on using tickets.