Opened 16 years ago

Closed 16 years ago

Last modified 10 years ago

#1409 closed defect (fixed)

FOTAQ: Crashes shortly after knocking guy down at Plane

Reported by: SF/phako Owned by:
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

scummvm -v: ScummVM 0.5.7cvs (Jan 21 2004 18:16:00)

scummvm segfaults, repruduction: Just play.

Language: German & English Floppy Version

Platform: Linux/i686 Debian Testing, GCC 3.3.3

Backtrace:

#0 0x40112c9e in SDL_CalculateAlphaBlit () from
/usr/lib/libSDL-1.2.so.0
#1 0x40112d69 in SDL_CalculateAlphaBlit () from
/usr/lib/libSDL-1.2.so.0
#2 0x40106e71 in SDL_UnRLESurface () from
/usr/lib/libSDL-1.2.so.0
#3 0x4011e2e2 in SDL_LowerBlit () from
/usr/lib/libSDL-1.2.so.0
#4 0x40120db8 in SDL_UpdateRects () from
/usr/lib/libSDL-1.2.so.0
#5 0x0804dfee in OSystem_SDL::update_screen()
(this=0x9344558)
at backends/sdl/sdl.cpp:359
#6 0x0815ad2c in Queen::Display::update(bool, short,
short) (this=0x93855d0,
dynalum=40, dynaX=40, dynaY=-14552) at
queen/display.cpp:615
#7 0x081509d5 in Queen::QueenEngine::update(bool)
(this=0x9354b60,
checkPlayerInput=false) at queen/queen.cpp:184
#8 0x0816d4a5 in Queen::Cutaway::handleText(int,
Queen::Cutaway::ObjectType,
Queen::Cutaway::CutawayObject&, char const*)
(this=0x9459d48, index=-10327660,
type=OBJECT_TYPE_TEXT_DISPLAY, object=@0x14,
sentence=0xbffff3d0 "... hoch über dem
Amazonas-Dschungel")
at queen/cutaway.cpp:1361
#9 0x0816c378 in Queen::Cutaway::run(char*)
(this=0x9459d48,
nextFilename=0xbffff5c0 "") at queen/cutaway.cpp:932
#10 0x0816a448 in Queen::Cutaway::run(char const*,
char*, Queen::QueenEngine*)
(filename=0xff626994 <Address 0xff626994 out of
bounds>,
nextFilename=0xff626994 <Address 0xff626994 out of
bounds>, vm=0xff626994)
at queen/cutaway.cpp:57
#11 0x081626ad in Queen::Logic::playCutaway(char
const*, char*) (this=0x1,
---Type <return> to continue, or q <return> to quit---
cutFile=0xff626994 <Address 0xff626994 out of bounds>,
next=0x9459d48 "`K5\tHĆB\t\002") at queen/logic.cpp:855
#12 0x0815646f in Queen::Command::executeIfCutaway(char
const*) (
this=0x936bd90, description=0x1 <Address 0x1 out of
bounds>) at queen.h:66
#13 0x081557e1 in
Queen::Command::executeCommand(unsigned short, short) (
this=0x1, comId=311, condResult=394) at
queen/command.cpp:345
#14 0x08154d52 in Queen::Command::executeCurrentAction() (t
at queen/command.cpp:188
#15 0x08151090 in Queen::QueenEngine::go() (this=0x9354b60)
at queen/queen.cpp:329
#16 0x08054024 in runGame (detector=@0xbffff810,
system=0x9344558)
at base/main.cpp:225
#17 0x08054252 in main (argc=-10327660,
argv=0xff626994) at base/main.cpp:313

Ticket imported from: #883841. Ticket imported from: bugs/1409.

Change History (8)

comment:1 by SF/phako, 16 years ago

Summary: FOTAQ Crashes shortly after knicking guy down at PlaneFOTAQ Crashes shortly after knocking guy down at Plane

comment:2 by joostp, 16 years ago

I can't seem to reproduce this with either the english or german
floppy version.

comment:3 by SF/twogood, 16 years ago

Jens,

I couldn't reproduce this bug with the English CD version of
the game data.

Did you get this after building a fresh CVS checkout, or did
you just update your CVS tree and ran make to build?

If the latter is the case, delete scummvm/queen/*.o and run
make again, then see if the bug is still there.

\David

comment:4 by fingolfin, 16 years ago

Status: newpending
Summary: FOTAQ Crashes shortly after knocking guy down at PlaneFOTAQ: Crashes shortly after knocking guy down at Plane

comment:5 by fingolfin, 16 years ago

Pending response by the bug submitter.

comment:6 by SF/phako, 16 years ago

Status: pendingclosed

comment:7 by SF/phako, 16 years ago

Bug gone with fresh CVS snapshot

comment:8 by Kirben, 10 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.