Opened 16 years ago

Closed 2 years ago

#1410 closed defect (fixed)

MI2: Two soundtracks playing at once

Reported by: SF/forge017 Owned by: BenCastricum
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

I have somehow gotten myself into a situation where
there are two soundtracks playing at once. One
soundtrack is stuck in an endless loop. It repeats every
20-30 seconds or so. It is the same soundtrack no
matter where I go in the game.

As I move about in the game, the primary track changes
with the appropriate area of the game. The secondary
looping track stays constant and ends up interfering
with the track that's supposed to be present.

I'm not sure how I got myself into this bug. I have not
been able to reproduce it. I have tried every setting I
can think of, but every time I load up the saved game,
the problem persists. Saved game attached for your
examination.

ScummVM version: Daily CVS snapshot on January 24,
2004, 5:12 pm

Language: English

Platform: Win32

Ticket imported from: #884000. Ticket imported from: bugs/1410.

Attachments (1)

monkey2.s01 (13.9 KB ) - added by SF/forge017 16 years ago.
Saved game with described problem. Wander around a bit to see how the problem persists.

Download all attachments as: .zip

Change History (16)

by SF/forge017, 16 years ago

Attachment: monkey2.s01 added

Saved game with described problem. Wander around a bit to see how the problem persists.

comment:1 by SF/forge017, 16 years ago

Summary: Two soundtracks playing at onceMI2: Two soundtracks playing at once

comment:2 by fingolfin, 16 years ago

Owner: set to SF/jamieson630

comment:3 by SF/jamieson630, 16 years ago

Can you remember approximately where you were in the game
when the one track started endlessly looping? Do you
recognize the track, or can describe it in any way? If you
were to hear the track again, would you recognize it?

If the answer to the last question is "yes," you can use the
iMuse debugger commands to iterate through the soundtracks
in the game and listen for the one that you were hearing over
and over.

Hit Ctrl+D to pull up the debugger window. Type "imuse play
#" where # would start at 1 and go upward. After it says it
has attempted to start track #, exit the debugger (Ctrl+D
again, I believe, or type "exit") and listen to the music. Note
that some track numbers will not produce music, or may only
be very short sound effects. Then go back to the debugger,
type "imuse stop all" to silence everything, and repeat again
with the next track number.

Any additional information of the sort requested above may
help us home in on the part of the game where the problem
started. Otherwise, since you cannot reproduce it and nobody
else has reported such a problem, there would be very little
we could do to determine where to start looking.

comment:4 by SF/bastula, 15 years ago

I just noticed the same problem with the 0.6 release on Mac OS X. I was
using the Quicktime driver. The place where this started happening was
when you first land on Booty Island, and then either go in a building or
change to the main Booty Island map. I returned to Scabb Island and the
issue of two soundtracks persists.

Also, I tried debugging as you mentioned - I couldn't figure out the track
number, but I know it happened also after going to the spitting contest
area. I will try messing around with it more and see what happens.

Finally, I tried loading a save game before that point and playing
through, trying to repeat, but I didn't get the double track effect.

Hope that helps

comment:5 by SF/risskin, 15 years ago

IMPORTANT!!!

Hi,

I remember having the very same problem - when I played the
game many years ago on my DOS computer!

It also appeared on Booty Island, and it was the very same
thing - one song kept playing in an endless loop, while the
others worked as they were supposed to.

THIS WOULD MEAN THAT THE BUG IS IN THE ORIGINAL GAME
CODE, NOT SCUMMVM!

I don't know what I did when I had this problem - I suppose I
just stopped playing...

Hope this helps a bit,
Matthias.

comment:6 by sev-, 14 years ago

Seems that there is no easy way to reproduce this and maybe
even it is only savegame in the world with this iMUSE
internal state inconsistency.

What is the status of this item?

comment:7 by fingolfin, 14 years ago

Well, there are at least two people who independently reproduced the
problem. We never figured out a particular reason why this occured; it
might indeed be a bug in the iMuse save/load code, but nothing is known.

The fact that this is hard to reproduce of course is sad, but doesn't mean
this isn't a bug, I am afraid :-/

comment:8 by fingolfin, 14 years ago

Owner: SF/jamieson630 removed

comment:9 by eriktorbjorn, 14 years ago

There used to be a problem, which I could only ever
reproduce when running the game in fast mode (Ctrl-F or
Ctrl-G) and moving quickly between rooms, that could make
two pieces of music play at the same time.

I think what happened was that the game tried to start a new
piece of music while one old piece of music was already
fading down and yet another one was fading up. The game
would try to stop the current music, but it never expected
that there could be more than one current piece. I guess it
picked the already fading-out music to stop, and let the
fading-in music continue.

I vaguely remember trying to fix this problem long ago, but
I also have an even vaguer memory of this fix causing subtle
problems in some other case, so I don't know what the
current status of it is. I tried reproducing it now, but the
worst problem I managed to provoke was being on the Scabb
Island overhead map without any music at all.

From what I remember, this fade-in/fade-out logic is all
scripted. Of course, our iMUSE implementation could differ
subtly from the original...

comment:10 by lordhoto, 10 years ago

Just for reference:

http://forums.scummvm.org/viewtopic.php?p=56069#56069

Claims to be a way to reproduce it. I'll quote (MusicallyInspired) here in case something goes wrong with our forums in the future:

I know exactly how to reproduce one version of this bug. What you do is go to woodtick, let the music play for a bit, then exit to the map screen and immediately click on Cpt. Dredd's ship. What I believe happens is the transition cues up from Woodtick to the Scabb Island theme but because you've clicked on Cpt. Dredd's ship so fast the game never got time to get the cue for the transition signal to end the Scabb Island theme because technically the Scabb Island theme wasn't even started yet (only the transition to it from the Woodtick theme) and thus the Scabb Island theme plays forever until you come back to Scabb Island and leave again giving it time to end its transition. To prevent this from happening, just wait until the Scabb Island theme actually starts when you leave Woodtick before going to Cpt. Dredd's ship.

Hope that makes sense. This happens to me every single time.

comment:11 by eriktorbjorn, 10 years ago

Thanks to MusicallyInspried, we may finally have a reproducable test case for causing two songs to play at once:

"I know exactly how to reproduce one version of this bug. What you do is go to woodtick, let the music play for a bit, then exit to the map screen and immediately click on Cpt. Dredd's ship."

Source: http://forums.scummvm.org/viewtopic.php?p=56069#56069

Though it's not 100% clear from his description, I assume this is a bit into the game, when the ship is anchored right beside Woodtick on the map, so you can get there almost instantly. At least, that's how I was able to reproduce it myself. That would fit with the "changing music too often, too quickly" theory that I had only seen in fast mode, a long time ago (in a galaxy far, far away).

comment:12 by eriktorbjorn, 10 years ago

Oops, somehow I missed LordHoto's post about it. I plead incompetence. :-)

comment:13 by SF/serrinatta, 8 years ago

I did encounter this problem, I and I was nearly ripping my hair out about it! Mostly because It took me several hours to even find someone who'd made comment about this (though I am notorious for using the wrong search parameters).

Now, using jamieson630's information to FIND the audio track, actually inclodes your solution to the issue.
Using the debugger (Ctrl+D)

Use the IMUSE section, specifically, the "imuse panic" command.

***This stops all audio tracks that are currently playing***

Then just walk into another area to load that area's sound as normal.

I do not know if the issue will occur again, but it's a good way to make it "STOP THAT!" (as I was yelling it repeatedly at my computer).

comment:14 by BenCastricum, 3 years ago

I have opened a pull request which should fix both (Booty and Scabb Island) of these issues.

https://github.com/scummvm/scummvm/pull/918

It would be great if anyone (besides me) could confirm this indeed fixes it. You don't need fast mode to reproduce them, a short explanation of how to trigger it is in the code.

comment:15 by BenCastricum, 2 years ago

Owner: set to BenCastricum
Resolution: fixed
Status: newclosed

The PR got merged.

Note: See TracTickets for help on using tickets.