Opened 15 years ago

Closed 15 years ago

#1395 closed defect (duplicate)

DIG: Crash (segfault)

Reported by: SF/vladr Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

See bugid 629302.

ScummVM CVS build 16-jan-2004

"The DIG" talkie (full CD) version, English (MD5:
d8323015ecb8b10bf53474f6e6b0ae33 -> dig.la0)

Printed text enabled in addition to speech.

Negative coordinates work their way into gfx.cpp as a
negative length passed to memcpy, part of text
erasing. Text erasing also had some less "fatal" issues
all throughout the game (some text would every now
and then remain unerased on the screen).

Savefile atached: simply click on the "panel" next to the
door and click on the right-most crystal until it becomes
a blue pyramid/tetrahedron, then the "door opening"
animation starts and the crash occurs.

Stack trace:

memcpy(unsigned char * 0x01d251fc,
unsigned char * 0x01d35644, unsigned
long 4294966451) line 171
Scumm::ScummEngine::blit(unsigned char *
0x01d251fc, const unsigned char *
0x01d35644, int -845, int 9) line 663
+ 17 bytes
Scumm::ScummEngine::restoreBG(Common::Rect
{...}, unsigned char 0) line 578
Scumm::CharsetRenderer::restoreCharsetBg() line 612
Scumm::ScummEngine::stopTalk() line 1202
Scumm::ScummEngine::CHARSET_1() line 172
Scumm::ScummEngine::scummLoop(int 5) line 1500
Scumm::ScummEngine::mainRun() line 1258 + 12 bytes
Scumm::ScummEngine::go() line 901

Ticket imported from: #878645. Ticket imported from: bugs/1395.

Change History (3)

comment:1 Changed 15 years ago by SF/vladr

Summary: Crash (segfault)DIG: Crash (segfault)

comment:2 Changed 15 years ago by Kirben

Closed as duplicate of #874501

comment:3 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.