Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1392 closed defect (duplicate)

CMI: Strangeness in the NUT renderer

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I wanted to test the pirate song scene in CMI. Not
having a savegame at hand, I used the boot param like so:

./scummvm -d 0 -b 465 comi

This starts the game at the end of the second chapter.
On my first two attempts however, ScummVM crashed. The
second time I traced the crash to
NutRenderer::drawShadowChar(). The debugger claimed
that 'dst' was out of bounds.

Adding some debugging messages, I discovered that on
several occasions y + _vm->_screenTop was greater than
vs->height. That can't be good, can it?

Ticket imported from: #877611. Ticket imported from: bugs/1392.

Change History (2)

comment:1 by Kirben, 16 years ago

Closed as duplicate of #874501

comment:2 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.