Opened 16 years ago

Closed 16 years ago

#1379 closed defect (fixed)

CMI: Failed assertion in the new digital iMUSE

Reported by: eriktorbjorn Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Using the latest CVS snapshot, I left CMI running for a
while in the first room, and got this:

Assertion failed: mixer_size >= 0, file
scumm/imuse_digi/dimuse.cpp, line 186

I don't know if it's easily repeatable or not.

Ticket imported from: #872339. Ticket imported from: bugs/1379.

Change History (3)

comment:1 by SF/ender, 16 years ago

This is easily reproducable, although it can be bypassed
by enabling the hack right above the assert.

This looks like a simple buffer overrun to me, is there
any reason the if (mixersize < 0) mixersize=0; code should
be commented?

comment:2 by SF/ender, 16 years ago

Owner: set to aquadran

comment:3 by aquadran, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.