Opened 15 years ago

Closed 15 years ago

#1380 closed defect (fixed)

COMI: Music / speech turns mute

Reported by: fingolfin Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

With latest CVS (and the new iMuse Digital):
In COMI, I am experiencing sever problems related to actor
speech. For example, in the canon scene, Wally stutters
(gets interupted by other SFX ?) and after a short time
seems to turn completely mute. I.e. subtitles still appear but
no voice is audible.

Ticket imported from: #872748. Ticket imported from: bugs/1380.

Change History (6)

comment:1 Changed 15 years ago by aquadran

it was caused by stopVoice(kTalkSoundId) called before
startVoice, it was called twice. i'm not sure how talk stuff is
working in scumm, but i see that it works fine now. and also
should be one speak played at same time, it's needed for
SYNC stuff.

comment:2 Changed 15 years ago by fingolfin

Summary: COMI: Actors 'stutter' / mutedCOMI: Music / speech turns mute

comment:3 Changed 15 years ago by fingolfin

Yeah, part of the problem seems fixed now. Good!

But there are still problems left. E.g. when I start COMI, and just
let it run (on the difficulty selection screen), after some time the
music turns mute. SFX will still play, though, and going to another
room (e.g. canon scene) again has working music.

comment:4 Changed 15 years ago by aquadran

Resolution: fixed

comment:5 Changed 15 years ago by aquadran

after fixes in jump code, loops are working now also for music

comment:6 Changed 15 years ago by aquadran

Status: newclosed
Note: See TracTickets for help on using tickets.