Opened 16 years ago

Closed 16 years ago

#1292 closed defect (fixed)

SAM: Mystery Vortex regression

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

At the Mystery Vortex, Sam and Max are no longer
growing/shrinking like they used to. I haven't verified
with the original interpreter that they should (I
haven't even checked if Sam & Max works in DOSbox now),
but I do know that some script keeps calling
o6_actorOps, case 92, to continuously change the scale
of actors 2 and 3.

However, this is all for nought since setupActorScale()
will then set up its own scale factor based on the
actor's current box before the costume is drawn.

I haven't had the time to descumm the scripts, so I
can't say any more about what's happening at this time.

There used to be a hack in setupActorScale() to fix
this (or possibly some other bug), but it was
apparently disabled for not making any sense. This
happened between revisions 1.175 and 1.176 of actor.cpp.

I don't have any god recent savegame to test this, but
you should be able to skip ahead to room 36 (outside
the vortex) with the debugger.

Ticket imported from: #833854. Ticket imported from: bugs/1292.

Change History (3)

comment:1 by eriktorbjorn, 16 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 16 years ago

Put a potential fix into CVS but can't try it ATM.

BTW, whoever sent me that Sam&Max IDA dump (to a text file), I
mapped/named tons of so far unnamed variables and functions, in
case you want to update your DB :-)

comment:3 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.