Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1234 closed defect (fixed)

ZAK: not all verbs are shown...

Reported by: SF/khalek Owned by: Kirben
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

in the Atari ST zak demo it shows verbs at the bottom
of the screen. Currently all of the verbs aren't
shown. If I recall correctly they used to all be
displayed with ScummVM...

screenshot of original and scummvm attached

Linux with latest CVS etc

Ticket imported from: #809033. Ticket imported from: bugs/1234.

Attachments (2)

svmzakdemo.png (18.1 KB ) - added by SF/khalek 16 years ago.
behaviour in ScummVM
zakstdemo.png (10.9 KB ) - added by SF/khalek 16 years ago.
original behaviour

Download all attachments as: .zip

Change History (6)

by SF/khalek, 16 years ago

Attachment: svmzakdemo.png added

behaviour in ScummVM

by SF/khalek, 16 years ago

Attachment: zakstdemo.png added

original behaviour

comment:1 by fingolfin, 16 years ago

I believe that this is caused by a change by Kirben:
<http://cvs.sourceforge.net/cgi-bin/viewcvs.cgi/scummvm/
scummvm/scumm/verbs.cpp.diff?r1=1.72&r2=1.73>

In particular, o2_verbOps (like o5_verbOps) attempts to redraw
the verb it modified at the end with these two lines:
drawVerb(slot, 0);
verbMouseOver(0);
However, the above mentioned changes prevent that from working
correctly.

comment:2 by fingolfin, 16 years ago

Owner: set to Kirben

comment:3 by Kirben, 16 years ago

Status: newclosed

comment:4 by Kirben, 16 years ago

Resolution: fixed
Note: See TracTickets for help on using tickets.