Opened 17 years ago

Closed 17 years ago

Last modified 2 years ago

#1233 closed defect (fixed)

MINGW: Build failure with recent CVS

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Port: Win32
Keywords: Cc:
Game:

Description

I get the following error message when I try to build the latest ScummVM CVS with MinGW:

make: *** No rule to make target `config.mak', needed by `base/gameDetector.o'.

The problem is that config.mak is never created since the MinGW build doesn't use the configure script. (Or does it, and I've just been doing it wrong lately?)

I was able to get around it by adding the following rule to Makefile.mingw:

config.mak: touch config.mak

(In case SourceForge mangles the whitespace, that's supposed to be a <TAB> before "touch", of course.)

But that seems like an evil hack to me...

Ticket imported from: #808364. Ticket imported from: bugs/1233.

Change History (5)

comment:1 by eriktorbjorn, 17 years ago

Owner: set to Kirben

comment:2 by eriktorbjorn, 17 years ago

Assigning to Kirben, since he's the one who's made most of the Makefile.mingw changes in the past.

comment:3 by fingolfin, 17 years ago

Owner: changed from Kirben to fingolfin
Resolution: fixed
Status: newclosed

comment:4 by fingolfin, 17 years ago

I removed the dependency on config.mak for now.

comment:5 by digitall, 2 years ago

Component: --Unset--Port: Win32
Note: See TracTickets for help on using tickets.