Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#1218 closed defect

COMI: Sound problem with Win2K

Reported by: SF/idx Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Problem: The music sounds almost as if it is played in slow-motion and then small parts are skipped to keep the sound syncronised with game. Occurences: Starts at very beginning of game, where you choose difficulty level. The music is slow, but the knife sound (hitting plank) works fine. The next small intro movie (Monkeys are listening) sound suffers the same anomaly. The intro movie also (ie. Music & Voice). Too slow. And then, in-game music. Also too slow. This somehow affects the sound effects (like Wally firing the cannon, but I haven't concentrated too much on that).

The last ScummVM version that worked (which I had in possesion) was v0.5.1, afterwhich the mixer was apparently rewritten.

*Compiled under VC6 for Win2K: Both the Release and Debug versions showed this error. *Compiled on Linux (Mandrake9.1): Worked fine, no problems.

Both compilations (and executions) were done on a 400Mhz Celeron. Windows running with DirectX 8.1. COMI is the only game in my possesion which showed this error. Both Day of the Tentacle and Beneath a Steel Sky performs correctly.

Does anybody out there suffer the same problem?

Ticket imported from: #803345. Ticket imported from: bugs/1218.

Change History (6)

comment:1 by fingolfin, 17 years ago

What do you think about this one, Ender? I can't reproduce it on my system, and so far haven't found anybody who could. Of course most people have faster machines (but note that it works just fine on my 400 Mhz G4 under OS X).

comment:2 by fingolfin, 17 years ago

Owner: set to SF/ender

comment:3 by fingolfin, 17 years ago

Status: newclosed

comment:4 by SF/ender, 17 years ago

Oops, didn't see you assign this one to me. I have no idea, I've never seen an issue like this before. The only vauge idea I have is that it could be somehow related to the lower timer resolution on Windows, somehow, maybe?

comment:5 by fingolfin, 17 years ago

Owner: changed from SF/ender to Kirben

comment:6 by fingolfin, 17 years ago

No idea either. But since it works fine under Linux on the system, it apparenly is indeed a windows specific issue. A pity we don't have more Windows coders on the team...

Reassigning to Kirben, our "windows man", in case he has anything to add.

Note: See TracTickets for help on using tickets.