Opened 16 years ago

Closed 16 years ago

#1212 closed defect (fixed)

LOOM: German EGA FD doesn't start, not found 82.lfl

Reported by: SF/wishbringer Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Loom

Description

Only happens with german ega fd version.
before something other happens ScummVM asks
for "82.lfl".
Error doesn't appear when starting normal loom.exe
(82.lfl maybe for choosing skill level)

Ticket imported from: #801103. Ticket imported from: bugs/1212.

Change History (14)

comment:1 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:2 by Kirben, 16 years ago

Download the Roland update from LucasArts or use the adlib
music driver. ie 'scummvm -eadlib loom' from command line.

comment:3 by fingolfin, 16 years ago

Uhm, what? That's not an acceptable answer IMHO, Kirben. Loom
should work "out of the box" for everybody.

comment:4 by fingolfin, 16 years ago

Status: closednew

comment:5 by Kirben, 16 years ago

Status: newclosed

comment:6 by Kirben, 16 years ago

It does work out of the box, since ScummVM defaults to Adlib
for all game now, this will only occur when users choose
global or game specific native midi driver.

comment:7 by fingolfin, 16 years ago

As many users do, like me. If Loom doesn't work with native midi
driver, it shouldn't allow selecting it. If it does work with it only
under special circumstances (namely if some additional files have
been installed), then add a new target for that (loom_roland or
whatever). But the current state is *not* acceptable. ScummVM is
not even given a proper error message, rather it just prints an
obscure error which in no way is related to the actual problem.

It's both in our interest and that of our users to fix this. First of,
users want an easy to use programm; secondly, we don't want
even more "bogus" bug reports every day because of this.

Please, don't close this again before the issue is resolved.

comment:8 by fingolfin, 16 years ago

Status: closednew

comment:9 by Kirben, 16 years ago

First note this issue effects both Loom [ega] and monkeyega..
That fact the Roland update is required for native MIDI
support is already mentioned in the README and compatibility
list.
Adding another target is not a good idea, we are just going to
confuse users even more and we want to avoid more targets.

The current ScummVM error is correct, although not very
helpful. The games only provide Roland sound resources when
VAR_SOUNDCARD=4 and they look in those particular files for
the Roland sound resources.
You could add a check for the extra files when native MIDI
support is requested in these two games and add a better
error message..
The files in Loom [ega] are 83.lfl - 85.lfl
The file in monkeyega is disk09.lec

comment:10 by Kirben, 16 years ago

Typo, that should be 82.lfl - 85.lfl for loom [ega]

comment:11 by fingolfin, 16 years ago

I insist on my point. The current behaviour is extremly confusing,
will lead to bug reports, and is avoidable. Hence it should be
fixed. Period.
Adding a separate target is but one suggestion on how to fix it. If
you can fix it by looking for the presence of certain files, fine,
suits me even better.

comment:12 by SF/logicdeluxe, 16 years ago

Wouldn't it be possible to check for the presents of the
extra Roland files, and if they aren't there, autoswitch to
Adlib and run the game anyways? This would be the most
intuitive way, as indy3 does autoswitch to Adlib as well,
for example. It wouldn't be confusing at all.

comment:13 by Kirben, 16 years ago

Resolution: invalidfixed
Status: newclosed

comment:14 by Kirben, 16 years ago

ScummVM now checks for extra files included in Roland
patches for loom & monkeyega, it give a better error if files
are not found.
I'm not sure if it is possible to safely switch music driver at
that point in code.

Note: See TracTickets for help on using tickets.