Opened 16 years ago

Closed 16 years ago

Last modified 14 years ago

#1173 closed defect (fixed)

BASS crashes after entering 4th room.

Reported by: SF/feathers1664 Owned by:
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

After entering the room to the right of where you first
build joey, it crashes with the following;

Music 3 requested but doesn't exist in file.!
scummvm: backends/sdl/sdl.cpp:211: virtual void
OSystem_SDL::update_screen(): Assertion `_hwscreen !=
__null' failed.
Aborted

This happens on both the CD & Floppy versions of BASS.

ScummVM 0.5.1 (Aug 6 2003 17:38:16) on Redhat 9.

Ticket imported from: #791207. Ticket imported from: bugs/1173.

Change History (8)

comment:1 Changed 16 years ago by lavosspawn

Is that crash reproducable?
Using a savestate or when restarting from scratch?
Did you play completely on 0.5.1 or loaded a 0.5.0 savestate?

comment:2 Changed 16 years ago by SF/feathers1664

Yes, its reproducable - it happens everytime, whenever I
start from scratch.

Its 0.5.1

comment:3 Changed 16 years ago by eriktorbjorn

Is there anyone (apart from feathers1664) who has managed to
reproduce this? I haven't, neither under Linux nor Windows,
and if it was a widespread problem, surely we'd have heard a
lot more about it...

comment:4 Changed 16 years ago by SF/toreanderson

Yes, I can, and several of the users of my Debian package can.

For details, see <http://bugs.debian.org/208499> and
<http://bugs.debian.org/208901>.

comment:5 Changed 16 years ago by eriktorbjorn

I think I finally see what's causing it, though I'm not sure
why I can't reproduce it in the CVS version because it looks
as if the bug might still be there.

What happens is that if you let the intro end on its own,
section 1 is never loaded. The game appears to think it
already is in that section. That's why you - well, I at
least - don't get the factory music either. It has the same
id (but different section) as the music at the end of the
intro, so it thinks it's already playing it.

If you terminate the intro, then it's forced to load section
1 because the "restore" flag is set, so everything works ok.

I'm not sure yet what the best way of fixing the bug is, but
the good news is that this means you can cut out most of the
intro from the game, and still be able to reproduce it.

comment:6 Changed 16 years ago by joostp

Fixed. Thanks eriktorbjorn :)

comment:7 Changed 16 years ago by joostp

Resolution: fixed
Status: newclosed

comment:8 Changed 14 years ago by fingolfin

Component: Engine: Sky
Game: Beneath a Steel Sky
Note: See TracTickets for help on using tickets.