Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#1155 closed defect (fixed)

Walk glitch

Reported by: eriktorbjorn Owned by: lavosspawn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

This is going to be an annoyingly vague bug report, I'm
afraid.

While replaying BASS (v0.0372) with the latest CVS
snapshot of ScummVM, there were two occasions where I
noticed actors were walking where they shouldn't be
able to walk.

* When leaving the room outside of Lamb's and Reich's
apartments, onto the walkway, foster walked through the
wall slightly to the right of the door.

* Outside the entrance to St. James it was suddenly
possible to walk across the water on the right side of
the screen.

In both case, saving the game and restarting ScummVM
fixed the problem, so whatever the error was it wasn't
stored in the savegame. Of course, that also means I
have no known way of actually reproducing the bug.

Could there be some memory corruption going on?

Ticket imported from: #788858. Ticket imported from: bugs/1155.

Change History (10)

comment:1 Changed 16 years ago by lavosspawn

Hmmm... class SkyGrid is reponsible for taking track of the
walk data. If you restore a savegame, the grid data is
reloaded from HDD...
The memory for the grid is malloc()ed, so if this is about
memory corruption, it should be noticable using
valgrind/electric fence...
How often did it happen to you? can you try it using valgrind?

comment:2 Changed 16 years ago by eriktorbjorn

While playing through the entire game (not in one sitting,
mind you) it only happened in those two cases, and I haven't
been able to reproduce them.

Playing through the entire game under valgrind on the
off-chance that it'd happen again would be painful...

comment:3 Changed 16 years ago by SF/kaod_

I had the same problem but I am unable to reproduce it...

comment:4 Changed 15 years ago by fingolfin

Status: newpending

comment:5 Changed 15 years ago by fingolfin

What is the status of this item?

comment:6 Changed 15 years ago by eriktorbjorn

Status: pendingnew

comment:7 Changed 15 years ago by eriktorbjorn

Dunno. I haven't played BASS lately, but I don't think much
has changed in the engine so I assume it's unchanged. Since
I never managed to figure out how to reproduce it, and the
bug isn't preserved in savegames, it's hard to say though.

It could be some kind of memory corruption, I guess, but my
computer isn't really fast enough to do any extensive
Valgrind testing on.

comment:8 Changed 15 years ago by lavosspawn

Resolution: fixed
Status: newclosed

comment:9 Changed 15 years ago by fingolfin

Owner: set to lavosspawn

comment:10 Changed 14 years ago by fingolfin

Component: Engine: Sky
Game: Beneath a Steel Sky
Note: See TracTickets for help on using tickets.