Opened 16 years ago

Closed 16 years ago

Last modified 10 years ago

#1123 closed defect (invalid)

All SFX delayed by 1/2 second

Reported by: SF/cheeth Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

Using ScummVM 0.5.0 RedHat RPMS on RedHat 9, with DOTT
English CD talkie.

All SFX, including voices, are about one-half second
later than they should be.

Ticket imported from: #783937. Ticket imported from: bugs/1123.

Change History (12)

comment:1 by fingolfin, 16 years ago

How is your music encoded? Plain .sou file, or did you encode it as
MP3 using the "extract" tool.
Also, did you try it with latest CVS (which has a different audio
mixer than both 0.5.0 and the upcoming 0.5.1) ?

comment:2 by SF/cheeth, 16 years ago

I'm using a standard monster.sou file. I'll try out CVS in
a bit and let you know how it goes. Either that or I'll
report compilation problems ;)

comment:3 by SF/cheeth, 16 years ago

Okay, I guess I wasn't joking after all. I've got a CVS
snapshot from Aug 6, and am having compilation problems.

./configure gives some ominous sdl messages:
Backend... sdl
Looking for sdl-config... sdl-config
./configure: line 1: sdl-config: command not found
./configure: line 1: sdl-config: command not found

and make gives more sdl errors:
/bin/sh: line 1: sdl-config: command not found
In file included from backends/sdl/sdl-common.h:26,
from backends/sdl/sdl-common.cpp:22:
common/scummsys.h:112:35: warning: SDL_byteorder.h: No such
file or directory
common/scummsys.h:114:13: warning: "SDL_BYTEORDER" is not
defined
common/scummsys.h:114:30: warning: "SDL_LIL_ENDIAN" is not
defined
In file included from backends/sdl/sdl-common.cpp:22:
backends/sdl/sdl-common.h:30:17: warning: SDL.h: No such
file or directory
backends/sdl/sdl-common.h:31:24: warning: SDL_thread.h: No
such file or directory

...and it pretty much gets worse from there. This is a
stock RedHat 9 install, and I haven't installed many (if
any) optional DEVEL packages. SDL is installed tho.

comment:4 by fingolfin, 16 years ago

Did you try a daily build http://www.scummvm.org/daily/ ?

If you don't have sdl-config in your path, then the SDL package
isn't installed (or at least isn't completely installed, period. The
configure script is only a placeholder, too, you can safely ignore it
for now. Just do a "make" (but again,. w/o sdl-config, that won't
work). OH yes, since you are on a RedHat system, you probably
don't have any MP3 libs installed, so you need to edit Makefile and
comment away the use of the MAD library (which provides MP3
abilities to ScummVM).

comment:5 by SF/cheeth, 16 years ago

Okay, the daily build 20030807 has the exact same
delay--approximately 1/2 second.

comment:6 by SF/cheeth, 16 years ago

I also confirmed this bug on the English Sam & Max CD
talkie. Same delay, both 0.5.0 and 20030807 CVS. I can't
test other platforms, but that might be a good idea.

comment:7 by fingolfin, 16 years ago

You are using an uncompressed monster.sou file, right? Could you
use the extract tool to generate a monster.so3, and test with that
as well? To see if it is delayed, too, or not. This would help to
narrow down the bug.

comment:8 by SF/cheeth, 16 years ago

Okay, I created a monster.so3 using the extract tool
compiled from 20030809 CVS. Playing with scummvm
20030807cvs and 0.5.0 both give me a half-second delay.
Incidentally, the sound quality was much improved in
20030807cvs!

comment:9 by eriktorbjorn, 16 years ago

Could it be arts or esd or something similar be introducing
a delay? (I've never really used them myself - they don't do
anything useful for me - so I don't know if they do that.)

comment:10 by SF/cheeth, 16 years ago

Sweet! Thanks Erik! Okay, disabling the aRts sound server
fixed it in CVS and 0.5.0. Looks like I may as well get
0.5.1 now tho ;)

Sounds like FAQ material to me (aRts is set to start up with
KDE by default, so this will be a common problem). I wonder
if there's any way to detect aRts and adjust sound timing
accordingly. Probably not worth the effort, considering
aRts could change and screw things up again.

comment:11 by SF/cheeth, 16 years ago

Status: newclosed

comment:12 by Kirben, 10 years ago

Owner: set to eriktorbjorn
Resolution: invalid
Note: See TracTickets for help on using tickets.