Opened 16 years ago

Closed 16 years ago

Last modified 14 years ago

#1124 closed defect (fixed)

scummvm hangs on ground level ringing the right door bell

Reported by: SF/cmjartan Owned by: fingolfin
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

ScummVM 0.5.3cvs
Language: de
Version sky-cd from your homepage
Platform: Win32

to reproduce: At the ground level, before or after Mrs
Piermont is leaving ringing the bell at her private
elevator.

Ticket imported from: #784375. Ticket imported from: bugs/1124.

Attachments (1)

SKY-VM.000 (52.2 KB) - added by lavosspawn 16 years ago.
Savegame at the door

Download all attachments as: .zip

Change History (9)

comment:1 Changed 16 years ago by SF/nath5000

with todays build i get the same problem, the music slows
down to a crall as well as the animation and scumm vm
controls freeze up and wont even let you alt-tab alt-escape
or ctrl-alt-delete to get out of the game.

comment:2 Changed 16 years ago by lavosspawn

Yes, indeed...
The SoundMixer crashes. Don't know why...
I'll assign it to fingolfin.

comment:3 Changed 16 years ago by lavosspawn

Owner: set to fingolfin

comment:4 Changed 16 years ago by fingolfin

I doN't even know who "Mrs Piermont" is (I never played BASS).
Give me a savegame or something like that, then maybe I can
look into it. Or better since you seem to know it's crashing in the
mixer, why not provide me a stack trace?

Changed 16 years ago by lavosspawn

Attachment: SKY-VM.000 added

Savegame at the door

comment:5 Changed 16 years ago by SF/florob

@fingolfin:
for there will be more such problems probably i think you
should play through BASS one time. I did in around 3 hours and
you have more practise i think.

comment:6 Changed 16 years ago by fingolfin

3 hours are 3 hours I don't have to spend on this.

Anyway after my recent audiostream.cpp changes, I loaded this
savegame, and couldn't reproduce any bad behaviour.

comment:7 Changed 16 years ago by lavosspawn

Resolution: fixed
Status: newclosed

comment:8 Changed 14 years ago by fingolfin

Component: Engine: Sky
Game: Beneath a Steel Sky
Note: See TracTickets for help on using tickets.