Opened 16 years ago

Closed 16 years ago

Last modified 10 years ago

#1107 closed defect (worksforme)

MI2: random crash/exit without error message

Reported by: SF/jurgendb Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

After launching MI2, scummvm exits without error
message. The moment of the crash is not always the same.
Problem first occurred for me in version 0.5.0. (Win32)
Linux version doesn't have this problem.
Scummvm version : 0.50
Game : Monkey Island 2 English
Platform : win32 - Windows ME

Ticket imported from: #782442. Ticket imported from: bugs/1107.

Change History (17)

comment:1 Changed 16 years ago by SF/jurgendb

Summary: random crash/exit without error messageMI2 - random crash/exit without error message

comment:2 Changed 16 years ago by fingolfin

Doest it really crash? When you say "without error", do you mean
it doesn't print any errors to the console, or that it doesn't show
an error dialog?

comment:3 Changed 16 years ago by fingolfin

Status: newpending

comment:4 Changed 16 years ago by SF/jurgendb

Yes, the application vanishes completely. May be the same as
reported in 782451

comment:5 Changed 16 years ago by SF/jurgendb

Status: pendingnew

comment:6 Changed 16 years ago by SF/jamieson630

Are you running ScummVM such that your console will remain
visible after the program exits? For instance, if you run
scummvm.exe from the Start/Run dialog, when it exits the
console will very likely disappear as well. Try opening a
command prompt manually and running ScummVM from within
it -- that way, even if ScummVM bombs the command prompt
(and ScummVM console output) should still be visible.

Also, what music driver are you using? -ewindows? Try
running with -eadlib or -enull to make sure the problem isn't
related to the music driver.

comment:7 Changed 16 years ago by SF/jurgendb

I tried running ScummVM from the command prompt, and it
didn't show any extra messages :
"C:\>scummvm
Using joystick: Microsoft PC-joystick driver
Looking for monkey2
Trying to start game 'Monkey Island 2: LeChuck's revenge'
C:\>"
I also tried the same with Indiana Jones & Fate of Atlantis,
with the same result : ScummVM exits after a few seconds,
so I suppose it's the same problem as reported in 782451.

comment:8 Changed 16 years ago by fingolfin

Does it work if you remove your joystick?

comment:9 Changed 16 years ago by fingolfin

Summary: MI2 - random crash/exit without error messageMI2: random crash/exit without error message

comment:10 Changed 16 years ago by SF/jurgendb

Yes, that's it : when I removed the joystick driver and
tried again, the problem was gone. Thanks.
Joystick is an old gravis gamepad :-)

comment:11 Changed 16 years ago by fingolfin

I have to wonder if we shouldn't just completely remove that
joystick code, or at least disable it by default. I hear a lot about
problems with it (crashes, mouse moves around due to
uncalibrated joystick), but no reports at all about people actually
using it.
Ender?

comment:12 Changed 16 years ago by fingolfin

Owner: set to SF/ender

comment:13 Changed 16 years ago by SF/ender

Owner: changed from SF/ender to SF/khalek

comment:14 Changed 16 years ago by SF/ender

I agree that it should be least be optional. Likewise, I
think the Keyboard-mouse emulation code should be
optional.

khalek, could you please do this for at least the joystick
code?

comment:15 Changed 16 years ago by fingolfin

I'll close this, as it's not a bug in MI2. But we need to think about
the Joystick code.

comment:16 Changed 16 years ago by fingolfin

Owner: SF/khalek deleted
Resolution: worksforme
Status: newclosed

comment:17 Changed 10 years ago by Kirben

Owner: set to fingolfin
Note: See TracTickets for help on using tickets.