Opened 16 years ago

Closed 15 years ago

#1084 closed defect (fixed)

FT: Talking choice menu causes overlapped actors to flicker

Reported by: SF/yarrt Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Tested with ScummVM:
ScummVM 0.5.0pre-cvs (Jul 22 2003 11:48:08)
ScummVM 0.5.0pre-cvs (Jul 26 2003 03:28:10)
OS: Windows 2000
Language: English
Build: Win32

Steps to reproduce:
1) Load save game
2) Move mouse cursor over choice
"Seem to have a lot of time on your hands."
3) Move mouse on/off that choice while
paying close attention to the knife-guy's
pants (below the table).

Does "scummvm" use double buffering ?

Ticket imported from: #778281. Ticket imported from: bugs/1084.

Attachments (1)

ft.s04 (68.7 KB) - added by SF/yarrt 16 years ago.
Watch the knife guys pants (below the table)

Download all attachments as: .zip

Change History (13)

Changed 16 years ago by SF/yarrt

Attachment: ft.s04 added

Watch the knife guys pants (below the table)

comment:1 Changed 16 years ago by SF/yarrt

Game: LoomFull Throttle

comment:2 Changed 15 years ago by SF/ender

Closing, does not occur in CVS anymore.

comment:3 Changed 15 years ago by SF/ender

Owner: set to SF/ender
Resolution: outdated
Status: newclosed

comment:4 Changed 15 years ago by Kirben

Owner: SF/ender deleted
Resolution: outdated
Status: closednew

comment:5 Changed 15 years ago by Kirben

Still occurs when I try with ScummVM cvs under Windows XP.

comment:6 Changed 15 years ago by SF/omega195

I just checked this bug, and it occurs in the CVS of today.
ScummVM 0.5.7cvs
Linux 2.6.1-rc1 / gcc 3.2.3

comment:7 Changed 15 years ago by fingolfin

Summary: FT: Talking choice menu flickersFT: Talking choice menu causes overlapped actors to flicker

comment:8 Changed 15 years ago by fingolfin

Correct bug description: it's not the menu/text which flicekrs, it's the
actor behind it. That in turn isn't a big surprise considering how verbs
work. Might try to think about a solution later.

comment:9 Changed 15 years ago by Kirben

Looking at the TV screen in the bar (With the save game)
causes some odd subtitle glitches too. Just try looking at TV
a few times.

comment:10 Changed 15 years ago by eriktorbjorn

The same thing also happens when talking to the bartender at
the beginning of the game. (I recently started re-playing
Full Throttle, determined to at least take a closer look at
every glitch I noticed. This was the first one. :-)

The problem appears to be that verbMouseOver() will clear
that part of the screen before drawing the highlighted
version of the verb. One simple workaround would be to have
scummLoop() call verbMouseOver() *before* calling
processActors(), instead of afterwards. I don't know if this
will break anything else, though.

comment:11 Changed 15 years ago by Kirben

Good idea, I just checked Full Throttle disasm. and it actually
calls verbMouseOver() before processActors(). The change
seems to be Full Throttle specific, since it doesn't occur in
disasm. of The Dig.

comment:12 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.