Opened 16 years ago

Closed 16 years ago

#1083 closed defect (outdated)

FT:Assertion failed: searchin

Reported by: SF/yarrt Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

ScummVM version:
ScummVM 0.5.0pre-cvs (Jul 26 2003 03:28:10)
ScummVM 0.5.0pre-cvs (Jul 22 2003 11:48:08)
does not occour in release version 0.4.1, though.

OS: Windows 2000
Language: English

Log Message:
Assertion failed: searchin, file scumm/resource.cpp, line
1794

Steps to reproduce:
1) load save game
2) open inventory (right click)
3) select meat
4) use meat with green car
(the one directly under the magnet)

4.1 behaviour:
Ben (actor) tries to walk to the green car, but
is stopped by the junkyard's watch dog.

Ticket imported from: #778266. Ticket imported from: bugs/1083.

Attachments (1)

ft.s03 (72.3 KB) - added by SF/yarrt 16 years ago.
Use meat on green car (under magnet)

Download all attachments as: .zip

Change History (12)

Changed 16 years ago by SF/yarrt

Attachment: ft.s03 added

Use meat on green car (under magnet)

comment:1 Changed 16 years ago by SF/yarrt

Summary: Assertion failed: searchinFT:Assertion failed: searchin

comment:2 Changed 16 years ago by fingolfin

Works for me. I do exactly as you describe, and indeed the dog
chases Ben away...

comment:3 Changed 16 years ago by fingolfin

It still works for me, but crashes for khalek. We tracked the
problem down to getObjectIndey returning -1 for object 155. Not
sure why, but I put in additional asserts, so that this case will be
caught before invalid memory is accessed.

comment:4 Changed 16 years ago by SF/yarrt

Fingolfin: Can you provide a checksum of your resource file /
the resource files name ? Perhaps the problem is a bad cd on
my/khalek's end. The previous Scummvm might have skipped
the missing object/defect resource without anyone noticing.
I haven't tested the scene with the game's original scumm
engine ... oh, can someone explain why the action part is still
missing (just got a nagging message box : "you can jump
now") :-(

comment:5 Changed 16 years ago by fingolfin

It's definitely not the data files. In khalek's case, object 155 first
was found correctly; only on the second try, getObjectIndex()
returned -1 (indicating that object 155 wasn't among the local
objects). A possible cause for this might be that the room was
changed by a script, and object 155 isn't available in the new
room, though that seems a bit odd. Or maybe the _objs array got
mangled.

The action parts are still missing because INSANE isn't
implemented (yet?). See http://scummvm.sourceforge.net/
compatibility.php?details=ft

comment:6 Changed 16 years ago by SF/khalek

I can't make this happen with latest cvs
yellow/blue cars work
and green car results in ben getting chased

note that the blue car is directly under the magnet not the
green

comment:7 Changed 16 years ago by fingolfin

What is the status of this item?

comment:8 Changed 16 years ago by fingolfin

Resolution: worksforme
Status: newpending

comment:9 Changed 16 years ago by SF/yarrt

Status: pendingnew

comment:10 Changed 16 years ago by SF/yarrt

May be closed. I can not reproduce it any more.

comment:11 Changed 16 years ago by fingolfin

Resolution: worksformeoutdated
Status: newclosed
Note: See TracTickets for help on using tickets.