Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1066 closed defect (invalid)

DOTT: Silence during timesurfing cutscene

Reported by: SF/wooshell Owned by: SF/jamieson630
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

In DOTT (english talkie version), in the first
timetravel cutscene, all sound is missing from the
moment Laverne is shown in her chron-o-john racing into
the future, until Hoagies chron-o-john hits the ground
in colonial times. Before and after that, all sound is
perfect.
This bug appeared first somewhere around the 0.4.1
release, and is existant until todays 0.5.0-pre cvs
version. I was only able to reproduce it on my Sun on
Solaris 8, but other (BE?) platforms might show that as
well. It does NOT occur in the Win32 version, though.

Ticket imported from: #775907. Ticket imported from: bugs/1066.

Change History (14)

comment:1 by fingolfin, 16 years ago

What do you mean, "appeared first somewhere around the 0.4.1
release" ? Does it happen in 0.4.1 or not? Note that 0.4.1 was
developed on a branch based on 0.4.0, separate from the main
trunk.

comment:2 by fingolfin, 16 years ago

Summary: Silence during timesurfing cutsceneDOTT: Silence during timesurfing cutscene

comment:3 by fingolfin, 16 years ago

Owner: set to SF/jamieson630

comment:4 by SF/wooshell, 16 years ago

I first noticed the bug with one of the cvs versions just
before 0.4.1,
but I dont know exactly when it was introduced.

comment:5 by SF/wooshell, 16 years ago

Sorry for my unclear expression. 0.4.1 was the first version
where I saw that bug, seems I just overlooked it with the
previous versions.

The oldest version I tested until now, that allows to
reproduce this bug, is ScummVM 0.3.0b from 06.Dec.2002 (from
the SF d/l server), with the adlib midi driver.
I also tested the win32 versions of that release date and
could NOT reproduce the bug there (neither with -eadlib nor
with -ewindows).
I dont know how to checkout even older versions, but it
seems this bug has always been there and gone unnoticed.

comment:6 by SF/jamieson630, 16 years ago

Not much I can do with this, since I only have LE systems
(more like *one* system, the Win32 box), and of course it
runs fine for me on there. Does someone with a BE system
running ScummVM, and a copy of the English talkie DOTT,
want to check this out?

When I have more time, I'll try to isolate the events going on
during that period and check to see if I can spot anything
that might cause an endian problem.

comment:7 by SF/jamieson630, 16 years ago

Priority: normallow

comment:8 by fingolfin, 16 years ago

Not sure what exactly I am supposed to reproduce here (does
"sound" refer to SFX or music or both in this context?), but at
least on my (BE) PPC Mac the music plays just fine with both the
CoreAudio and the QuickTime driver. Maybe I have to try with -
eadlib?

comment:9 by SF/jamieson630, 16 years ago

Hmm, would this be a Solaris problem specifically, then?

wooshell, which platform are your DOTT data files from -- the
Win32 version? I just want to be sure both you and Fingolfin
are running the same data files on your respective BE
systems, just in case a difference in the data files might
cause this bug to show up or disappear.

comment:10 by SF/wooshell, 16 years ago

It might well be a Solaris-only problem, but I wonder why I
don't get similar effects in other cutscenes or within other
games on scummvm. I would appreciate any hints for bug
hunting on my system.
I used an English Talkie version, but as I don't keep the
exe files and the CD doesn't have any distinctive text on
it, I can't tell where the data files are from.
The md5sum of tentacle.001 is
c5d451e659e0915ac02f5807de3a0bc0, if that's of any help. If
there's a discrepancy, I could make the data file available
to you or Fingolfin for diff'ing.

comment:11 by SF/jamieson630, 16 years ago

That md5sum matches the one I have for the MSDOS English
CD Talkie version of DOTT. So the data I'm working with
matches what you're working with.

One thing you can do is uncomment (enable) the #define
IMUSE_DEBUG at the top of imuse_internal.h. Then, log the
console output of ScummVM to a file, starting, for instance,
just before the Chrono-John diamond shatters, and ending a
few seconds after the first "falling closeup" where you're not
getting any sound. (Is Laverne the first one? You mentioned
that she's where the sound stops.)

comment:12 by SF/wooshell, 16 years ago

I put the log on http://www.dreamforge.de/error.txt and hope
it's sufficiently commented.. I can't read a single thing
out of it :o)

When the "camera" switches from Bernard's CoJohn to Laverne's,
the last music notes end (not abruptly, rather the normal
fadeout) and then silence.
Sound starts quite abruptly as soon as Hoagies CoJohn hits
the ground, with the crash sound effect and somewhere in the
middle of the tune, AFAICS exactly on the place where it
should be at that moment. (just a few notes left to the end
of that tune.)

comment:13 by SF/jamieson630, 16 years ago

This is a platform performance issue. Apparently with any kind
of graphics scaler in use, the animation for the cutscene is
running too slow on wooshell's machine. As a result, the music
is reaching the end before the switch from Bernard to Laverne
occurs, and that particular music is not set up to loop. So,
the player shuts down, and since the tracks for all three
shots are part of the same music resource, none of them play
after that. This is normal and proper behavior.

The silence phenomenon will also happen on any other
platform using -t200 to play the music at 200% its normal
speed. Same idea: music ends before the animation does.

comment:14 by SF/jamieson630, 16 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.