Opened 16 years ago

Closed 15 years ago

#1064 closed defect (fixed)

DOTT: Actor glides instead of walks (regression)

Reported by: eriktorbjorn Owned by: Kirben
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

[Extracted from bug report #775097]

English CD "talkie" version

At the end, when the kids are running away from
purple tentacle, there's a brief sequence on the second
floor where they are gliding instead of walking. I
think this used to work, but I can't say for sure when
that was.

I think it may have something to do with
startWalkAnim() not being called from actorWalkStep(),
but I don't know how to fix it.

I'm pretty sure this used to work the last time I
played the game - somewhere between 0.2.0 and 0.3.0
probably. I don't know about 0.4.0 / 0.4.1.

Ticket imported from: #775662. Ticket imported from: bugs/1064.

Attachments (3)

tentacle.s32.gz (17.1 KB) - added by eriktorbjorn 16 years ago.
Savegame near the end of the game
tentacle.s50.gz (10.9 KB) - added by eriktorbjorn 16 years ago.
Savegame closer to the bug
tentacle.s20 (16.8 KB) - added by eriktorbjorn 15 years ago.
Savegame (compressed) near end of game

Download all attachments as: .zip

Change History (15)

Changed 16 years ago by eriktorbjorn

Attachment: tentacle.s32.gz added

Savegame near the end of the game

Changed 16 years ago by eriktorbjorn

Attachment: tentacle.s50.gz added

Savegame closer to the bug

comment:1 Changed 16 years ago by fingolfin

Well startWalkAnim() is not being called because facing ==
direction == 90 and also frame == walkFrame == 2.

That's correct logic: if the frame is already the walkFram, and we
are not turning: don't do aynthing. Otherwise, you'd get stutter in
the movement. So, the question remains, why doesn't the actor
'walk' properly? Is 'frame' maybe out of sync with reality? Or is for
some reason the actor animation counter not being incremented?

comment:2 Changed 16 years ago by SF/lordtoran

I had this in the German disk version too.

comment:3 Changed 15 years ago by Kirben

According to disasm., frame should always be set to 0 in
startAnimActor() for tentacle, which triggers a walk in this
situation. I have added fix to cvs.

comment:4 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:5 Changed 15 years ago by Kirben

Owner: Kirben deleted
Resolution: fixed
Status: closednew

comment:6 Changed 15 years ago by Kirben

Nevermind, misread code.

comment:7 Changed 15 years ago by SF/ender

Priority: normallow

Changed 15 years ago by eriktorbjorn

Attachment: tentacle.s20 added

Savegame (compressed) near end of game

comment:8 Changed 15 years ago by eriktorbjorn

Since I've played through DOTT with a January 23 CVS
snapshot, I can confirm the glitch is still there. I'm
attaching an up-to-date savegame.

comment:9 Changed 15 years ago by Kirben

Summary: DOTT: Actor glides instead of walks (regression?)DOTT: Actor glides instead of walks (regression)

comment:10 Changed 15 years ago by Kirben

This is a regression but it only worked before actor.frame
support was added.

comment:11 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:12 Changed 15 years ago by Kirben

The problem was we were changing the value of actor.frame
even if the actor's frame was not updated. Verified by disasm.

Note: See TracTickets for help on using tickets.