Opened 16 years ago

Closed 16 years ago

#1049 closed defect (fixed)

Zak: Annie walking in funny places

Reported by: SF/voodoofx Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

ScummVM version: ScummVM 0.5.0pre-cvs (Jul 20 2003
11:57:11)

Platform: win32(WinXP)
Zak version: v2(enhanced)
language: english

When i drop the blue crystal in Annie's dropslot and run
to the bus, Annie follows Zak. Well she must be
spiderman, since she is walking on the wall :)))

Picture attached

Ticket imported from: #774529. Ticket imported from: bugs/1049.

Attachments (2)

zak9.JPG (40.0 KB) - added by SF/voodoofx 16 years ago.
Annie walking on the wall
zak64.s06 (52.2 KB) - added by Kirben 16 years ago.
Drop Blue Crystal in slot and run to bus stop.

Download all attachments as: .zip

Change History (8)

Changed 16 years ago by SF/voodoofx

Attachment: zak9.JPG added

Annie walking on the wall

comment:1 Changed 16 years ago by fingolfin

Attaching a savegame to reproduce this would be useful (assuming
you can still reproduce the issue with latest CVS).

Changed 16 years ago by Kirben

Attachment: zak64.s06 added

Drop Blue Crystal in slot and run to bus stop.

comment:2 Changed 16 years ago by Kirben

I have attached a game from V1 zak, where problem also
occurs. Just drop Blue Crystal in slot and run to bus stop.

comment:3 Changed 16 years ago by fingolfin

I wonder what happens in the original here? Can you "run away"
there, too? Or is Zak maybe meant to be immobile? If you can run
away, what does happen?

comment:4 Changed 16 years ago by Kirben

Yes Zak can run back to bus stop in the original game and the
same scene occurs but Annie walks along the footpath
correctly. I checked the original version of Zak McKracken
(Enchanced).

comment:5 Changed 16 years ago by fingolfin

The problem here is that the walk matrix is foobar, and confuses
our walk algorithm. V1/V2 apparently employ a different (simpler
& cruder) algorithm. I'll look into implementing that one.

If you want to know a bit more details: When Annie enters the
room, she is in box 8, and tries to get to box 5. Problem is, the
walk matrix claims that box 8 and 5 are adjacent. They are not
(and indeed, if you do a reverse lookup, it tells you that to get
from 5 to 8, you have to go via box 10, which is correct).

Due to the simplistic algorithm in V1/V2, the problem wasn't
noticed.

comment:6 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.