Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1025 closed defect (fixed)

0.5.0 RC: LOOM: Crash with shepherds

Reported by: SF/kpharris Owned by: fingolfin
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

The game is completable with 0.5.0pre-cvs (2003-07- xx), which was downloaded from this mornings compiled snapshot (win32), but does have some bugs.

When talking to the shepherds, trying to use different drafts on them has caused crashes for me. Attached is a savegame just before you reach them (they are to the left). As I seem to remember the drafts being different for each play, here's a few: ECED-open CEEG- camouflage, DDCD-Dye. After trying a few variants of random drafts, the GEEC thread crashes ScummVM with this error message: ERROR: (23: 232: 0x623D): Invalid actor 0 in actortalk

Sorry, but I haven't tested it with 0.4.1. I also have no other versions of loom to test it.

I was testing it to complete a report (as it said it needed testing this morning), but someone else finished first.

Ticket imported from: #770724. Ticket imported from: bugs/1025.

Attachments (1)

loom.s02 (57.8 KB ) - added by SF/kpharris 16 years ago.
Loom game saved just before the shepherds

Download all attachments as: .zip

Change History (5)

by SF/kpharris, 16 years ago

Attachment: loom.s02 added

Loom game saved just before the shepherds

comment:1 by SF/ender, 16 years ago

Priority: normalblocker

comment:2 by SF/ender, 16 years ago

Priority UP!

comment:3 by fingolfin, 16 years ago

The problem is that in this script room-23-232, there is this line:

[0012] (94) print(Local[0],[Center(),Text("We are the masters of stealth,^255^1little wizard.")]);

However, when script 232 is invoked it *never* receives any parameters. Hence Local[0] will be at 0! Which causes the error.

For now, I put a workaround into CVS.

comment:4 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Summary: 0.5.0 RC: LoomEGA crashes with shepherds0.5.0 RC: LOOM: Crash with shepherds
Note: See TracTickets for help on using tickets.