Opened 16 years ago

Closed 16 years ago

#1009 closed defect (fixed)

INDY3EGA: 2nd trial, Jehovah spelling not visible

Reported by: SF/quietust Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Indiana Jones 3

Description

In the 2nd trial, Indy says the following text:

> In Etaskrit, Jehovah is spelled "".

The following warning appears at the console each time
Indy says this.

WARNING: getResourceAddress Illegal Glob type String
(7) num 53!

Without having played that section before, it becomes
rather difficult to win.

Savestate attached.

Ticket imported from: #770360. Ticket imported from: bugs/1009.

Attachments (1)

indy3ega.s02 (52.2 KB) - added by SF/quietust 16 years ago.
In Etaskrit, Jehovah is spelled "".

Download all attachments as: .zip

Change History (8)

Changed 16 years ago by SF/quietust

Attachment: indy3ega.s02 added

In Etaskrit, Jehovah is spelled "".

comment:1 Changed 16 years ago by SF/quietust

Summary: INDY3EGA: Amiga - 2nd trial, "Iehova" speech not visibleINDY3EGA: Amiga - 2nd trial, Jehovah spelling not visible

comment:2 Changed 16 years ago by SF/dfabulich

Reproduced on Spanish EGA version, Win2K, ScummVM
0.5.0pre-cvs, Built on Jul 14 2003 03:24:03. In fact, this
makes the puzzle more than difficult: it's impossible to do
without trial and error. The "name of God' is chosen
randomly every time you play, so you just have to guess what
it is, saving and restoring (which is technically cheating
at this point in the game) to get through this trial.

comment:3 Changed 16 years ago by Kirben

Summary: INDY3EGA: Amiga - 2nd trial, Jehovah spelling not visibleINDY3EGA: 2nd trial, Jehovah spelling not visible

comment:4 Changed 16 years ago by fingolfin

Hm, this save game is for english indy3ega ? It doesn't work for
me, when loading it with latest CVS I get:
(84:205:0x430C): Value 32 is out of bounds (0,20) (Local variable
32 out of range(r))

comment:5 Changed 16 years ago by SF/quietust

ScummVM 0.5.0pre-cvs (Jul 20 2003 00:33:19) - works fine
now. This was probably fixed along with #770344.

By the way, the reason the savestate wouldn't work is
probably because it's for the Amiga version of Indy3ega (this
used to be obvious until kirben renamed the bug).

comment:6 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:7 Changed 16 years ago by fingolfin

Cool. Always nice to fix two bugs with one change ;-)

Note: See TracTickets for help on using tickets.