Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1008 closed defect (fixed)

INDY3EGA: Amiga - music timer running way too fast

Reported by: SF/quietust Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

As music playback is currently disabled, it's hard to tell
that music is playing too quickly, but there are 2 places
where it becomes evident:

1. The intro, from start to end, is playing in about 34.6
seconds with ScummVM. On my Amiga, the song takes
52 seconds to play back completely (and the intro
doesn't end until the song is done).

2. In the Zeppelin, playing a song on the piano to get
into the radio room leaves me with way too little time to
get the wrench and smash the radio (about 5 seconds
after I enter the room, even if I click as fast as humanly
possible).

Ticket imported from: #770352. Ticket imported from: bugs/1008.

Change History (6)

comment:1 by SF/quietust, 16 years ago

Now that I understand the code a bit better, the problem is
that there is NO music timer, and there are events that don't
work properly (the aforementioned zeppelin part) if there's no
timer.

comment:2 by Kirben, 16 years ago

There is a music timer, check around line 1219 of
scumm/scummvm.cpp. I adjusted the music delay and intro.
duration seems right now when compared to PC version, can
you recheck out location ?

comment:3 by Kirben, 16 years ago

Can you recheck the other location I mean.

comment:4 by SF/quietust, 16 years ago

Much better, though now it's a bit too slow (55 seconds
instead of 52).
One of the main problems with the Amiga version is that the
timing is not 100% exact - with a faster CPU, the intro
actually runs faster (but still ends at the exact instant the
music stops), while with a 7.14MHz 68000 (the original Amiga
CPU), animation is extremely choppy.
Similar problems can be seen with Zak McKracken - with a
fast CPU, the "zoom in on the map" bit in the intro goes super-
fast, leaving you at the end of the intro a LOT longer than
otherwise expected.

comment:5 by Kirben, 16 years ago

I made a small adjustment to music timer, it is now using
same timer value as Adlib. There is a minor 1-1.5 second
difference but it is close enough and using correct value, so
I'm closing bug.

comment:6 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.