Opened 16 years ago

Closed 16 years ago

#985 closed defect (fixed)

LOOM/CD: Distaff sporadically loses bits

Reported by: SF/dfabulich Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

Play the game for a while. After walking around for a bit, a chunk of the distaff will be gone: a letter will disappear, a corner of the staff may vanish, etc. The letters will regenerate when you click on them, and the staff itself will be regenerated after a conversation or something, but this is kind of annoying. I can't find any way to reproduce this reliably, unfortunately. :(

Win2K, ScummVM 0.5.0pre-cvs, Built on Jul 10 2003 20:29:19

Ticket imported from: #770039. Ticket imported from: bugs/985.

Change History (13)

comment:1 by SF/inguin, 16 years ago

I can reproduce it (Loom, german EGA version, latest CVS, Linux). It always happens when entering a new room, e.g. if I leave the dock after opening the clam. Whichever letter I hit last disappears from the distaff.

comment:2 by fingolfin, 16 years ago

Summary: Loom EGA: Distaff sporadically loses bitsLOOM: Distaff sporadically loses bits

comment:3 by Kirben, 16 years ago

This problem also occurs in Loom [CD] sometimes.

comment:4 by Kirben, 16 years ago

Summary: LOOM: Distaff sporadically loses bitsLOOM/CD: Distaff sporadically loses bits

comment:5 by Kirben, 16 years ago

This problem effects fresh game from the start too, so definately isn't related to other problem that occur after load/save of game.

comment:6 by Kirben, 16 years ago

Closed as duplicate of #770049, since they both have same cause.

comment:7 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: duplicate
Status: newclosed

comment:8 by fingolfin, 16 years ago

How do you now those bugs have the same cause? The only way to know would be to have a fix, which you say you don't... all I see is that it *seems* that these two bugs may have the same *triggers*, but the resulting buggy may very well be due to two different bugs :-)

comment:9 by Kirben, 16 years ago

Well in the test case of 'open clam and change room', script 16 is started as the new room loads and all it basically does is an empty talk string: [0000] (9A) Var[166] = Local[0]; [0005] (14) print(1,[Spacing?(10),Center(),Pos(160,Var [166]),Text("")]); [0012] (A0) stopObjectCode() END

Script 16 is started by script 10002, I'm not sure what the number refers to as that script doesn't exist.

comment:10 by fingolfin, 16 years ago

Owner: changed from Kirben to fingolfin
Resolution: duplicate
Status: closednew

comment:11 by fingolfin, 16 years ago

I put a workaround for bug #770049 into CVS. It may or may not also fix this issue, too. Please test.

comment:12 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed

comment:13 by Kirben, 16 years ago

I see script 10002 means entry script, so room 3 entry script always starts script 16: startScript(16,[16])

I wonder what the original game did in this situation. Anyway the work around you added solves the problem.

Note: See TracTickets for help on using tickets.