Opened 9 years ago

Closed 9 years ago

Last modified 13 months ago

#9249 closed patch (invalid)

ANDROID: Alternative Touchscreen Mouse

Reported by: SF/mcnicholls Owned by: anguslees
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

I have added an alternative mouse implementation that handles right click with a long press.

This implementation will:

On a touch down event send no ScummVM event on.
Any touch move events will send a ScummVM mouse move.
A touch up will send a left button down ScummVM event followed by a left button up ScummVM event.
If you have touched the screen for longer than a second and don't move it too much then it will perform haptic feedback to let you know it will perform a right click when you release the touch.

This implementation can be triggered from the menu key, which now presents an Android menu as well as showing the ScummVM menu.
This Android menu allows you to switch between the current and alternative behaviour.

This implementation may not be a correct fit for all engines, but can serve as a starting point to find something that works.

Ticket imported from: #3104277. Ticket imported from: patches/1354.

Attachments (1)

android-alternative-mouse.patch (8.1 KB ) - added by SF/mcnicholls 9 years ago.
Alternative Touchscreen Mouse Handling

Download all attachments as: .zip

Change History (7)

by SF/mcnicholls, 9 years ago

Alternative Touchscreen Mouse Handling

comment:1 by jvprat, 9 years ago

Owner: set to anguslees

comment:2 by dhewg, 9 years ago

damn, another item i didn't notice before. either i suck at using this tracker or the tracker sucks.
i'm afraid this patch is invalid now, since the bulk of the input code is on the c++ side now.
on the bright side, i think the touch events on master are implemented like you describe (except for the haptic feedback), which might get annoying on games like full throttle and sam&max.
but i'll check how you implemented the menu, thats something still missing on master.
sorry!

comment:3 by dhewg, 9 years ago

Resolution: invalid
Status: newclosed

comment:4 by SF/mcnicholls, 9 years ago

no problem Andre.

I am just glad it has been found and am pleased that you have got some code to do this.

What is the best way to get patches noticed?

Not sure if it has been addressed, but when installing and uninstalling I tend to lose my save games.
I was thinking of implementing a backup manager for 2.2+ that backs save games to the cloud (as originally
suggested by Gus), or maybe saving games to the SD card, or possibly both?

Maybe this has been done all ready?

comment:5 by dhewg, 9 years ago

attaching patches to this patch tracker is exactly the right thing to do.
it's just that i didnt plan on working on the android backend at all, somehow i bought a tab and it just happened :) i learned about the system while working on bits, and looked at tracker items too late...

there's currently no code that deals with savegame backups. i've seen the cloud API, but that won't fix the savegame issue for everyone. you need a sync account, and users can't select which apps should use it. since it also syncs private data like wlan access point passwords, i for one didn't enable it on purpose.
but you can set the savegame path in the options to sd today, and just by a feeling i think that would probably the better idea. just point to sd per default. the issue is the transition, where we have to move savegames from the internal data path to the new directory, so those don't get lost when users upgrade.

comment:6 by digitall, 13 months ago

Component: Port: Android
Note: See TracTickets for help on using tickets.