Opened 16 years ago

Closed 15 years ago

#895 closed defect (fixed)

COMI: Cannot get past "singing pirates" scene

Reported by: SF/jessieleah Owned by: aquadran
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I sent this to scummvm-tracker first, but got told I
had to go through the whole rigmarole of registering
and using the bug tracking system here... so here I am.

Please help with this issue.

I run ScummVM 0.4.1 on Mac OS X (from the "official"
released binaries from SourceForge).

I just got aboard the ship for the first time, with the
crew (a.k.a. the three guys from the Barbery Coast
barber shop).

The duel sequence with Captain Rottingham plays out
fine. He runs off with the map. Then, when talking with
my idiot crew, someone says "That reminds me of a
song." All three crewmembers, plus Guybrush, burst into
song...
...
...
...
...
...
...and keep singing...
...
...
...
...
...and keep singing...
...
...etc.

Hitting escape does nothing. I tried diddling around in
the console... I tried "scr kill [scriptnumber]" on
various scripts... did nothing. In fact, the scripts
still showed up in the list when I typed 'scripts'.
Apparently, they are unkillable.

PLEASE help.

Ticket imported from: #755826. Ticket imported from: bugs/895.

Change History (6)

comment:1 Changed 16 years ago by SF/ender

Keywords: script removed
Owner: set to aquadran
Priority: normalhigh

comment:2 Changed 16 years ago by SF/ender

aquadran, do you have time to look at this?

I assume the problem is the semi-stubbed V8 kernel
functions imGetMusicPosition, although it may also be
related to musicLipSyncWidth/musicLipSyncHeight. I believe
the last two are just cosmetic tho, and only the first is
used for script jumping.

comment:3 Changed 16 years ago by fingolfin

Summary: Cannot get past "singing pirates" sceneCOMI: Cannot get past "singing pirates" scene

comment:4 Changed 16 years ago by SF/superqult

I managed to get through the singing-pirates scene, but it
behaved in a very strange fashion. I'm using an Aug 24 2003
build.

comment:5 Changed 16 years ago by SF/ender

The rewrite of the necessary code to correct this issue in
currently in progress.

comment:6 Changed 15 years ago by Kirben

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.