Opened 16 years ago

Closed 16 years ago

Last modified 11 months ago

#8235 closed patch (fixed)

LOOM: sound support

Reported by: SF/hoenicke Owned by: SF/hoenicke
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

Loom sounds are very similar to Zak & MM ones. Only a
new opcode was added.

I'm not completely sure if the sounds are really meant to
sound this way. Maybe someone can check this under
DOS.

Also someone should check whether indy3ega works. I
don't have this game.

Ticket imported from: #744100. Ticket imported from: patches/340.

Attachments (3)

loom-sound.diff (3.7 KB ) - added by SF/hoenicke 16 years ago.
patch to support loom music.
new_loom.patch (3.0 KB ) - added by Kirben 16 years ago.
loom-sound-new.diff (3.7 KB ) - added by SF/hoenicke 16 years ago.
This should apply cleanly.

Download all attachments as: .zip

Change History (13)

by SF/hoenicke, 16 years ago

Attachment: loom-sound.diff added

patch to support loom music.

by Kirben, 16 years ago

Attachment: new_loom.patch added

by SF/hoenicke, 16 years ago

Attachment: loom-sound-new.diff added

This should apply cleanly.

comment:1 by SF/florob, 16 years ago

Well I tryed this with the pass demo i don't know if the result is the
same with the real game, but with pass it sounds the same as before
and that means it sounds good!

comment:2 by Kirben, 16 years ago

If the patch is applied indy3ega should be excluded. The
patch doesn't work with indy3ega music and causes it to
crash, although indy3ega sound effect seem ok.
Also the patch causes Amiga version of Loom to crash, so
would be best to find a way to exclude Amiga versions
sound/music if possible too.

comment:3 by fingolfin, 16 years ago

Owner: set to SF/hoenicke

comment:4 by fingolfin, 16 years ago

This sounds OK in loom for me (well OK = melody is right. sounds crap
compared to Loom CD of course :-)

The indy3ega issue should be addressed before this is applied. I wouldn't
worry to much about Loom amiga for now; although, it would be nice to fix
this, but if you don't ahve loom amiga files it might be non-trivial to do so.

comment:5 by Kirben, 16 years ago

I just tried enabling support in ScummVM cvs:
indy3ega and loomdemo no longer crash
I get some music in indy3ega now but some music is cut
short (Like opening theme). Try testing with the indy3ega non-
interactive demo at http://files.mixnmojo.com/indydemo.zip
The music in loomega demo sounds wrong after the restart
point, it seems like music isn't restart/stopped at restart point.

I have enabled support in ScummVM cvs now since crash
issues are gone and just used Amiga option as bypass for
Amiga versions of indy3 and loom.

comment:6 by Kirben, 16 years ago

A few more notes:
There is no sound effect when Indy is walking, maybe the
walking function should automatically play a sound effect on
movement ? since there are no playSound calls I can see.
The no sound effect when walking problem also effects Zak
McKracken.

There is no music looping in indy3ega, I checked original and
it does loop for pc pseaker music.

comment:7 by fingolfin, 16 years ago

On my (big endian) system, indy3ega plays 3-4 notes in the intro, then stops
-> clearly wrong

Loom (EGA) music seems to play fine, although there are some places where
it sounds odd compared to the original (as if some sound/channel wasn't
played, maybe?)

comment:8 by SF/hoenicke, 16 years ago

The indy intro song is fixed now. There were some new note
lengths missing. Also there was a bug with hull curves
breaking internote-spacing,

There are still odd snippets in Loom music, but they are not
always reproducible.

comment:9 by SF/hoenicke, 16 years ago

Resolution: fixed
Status: newclosed

comment:10 by digitall, 11 months ago

Component: Engine: SCUMM
Game: Loom
Note: See TracTickets for help on using tickets.