Opened 13 years ago

Closed 5 years ago

#7461 closed enhancement (wontfix)

SCUMM: MI1 EGA Italian Floppy missing vowels

Reported by: SF/gourry Owned by:
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

ScummVM version: all
Game: Monkey Island EGA
Version: Floppy
Language: Italian

Description: Vowels with stress (à, è, ì, ò, ù) are
not displayed at all (while "é" is displayed
correctly)

This bug was present, also, in original game so I
don't know if it's a bug or a feature.

I thought that vowels with stress were missing from
game scripts (as when I played it 13 years ago they
weren't shown in DOS either), then when I saw that
ScummVM showed "é" correctly, I opened scripts with
ScummEX and found that every character was coded but
not displayed.
Mapping is:

^133 --> à
^138 --> è
^141 --> ì
^149 --> ò
^151 --> ù

Well, actually I don't know if letters are not
displayed in ScummVM to be compliant with DOS
behaviour... but since thay are there I think it
would be a bugfix to show them!

Best Regards

Ticket imported from: #1385126. Ticket imported from: feature-requests/277.

Change History (12)

comment:1 Changed 13 years ago by fingolfin

Component: Engine: SCUMM
Game: Monkey Island 1
Keywords: script removed

comment:2 Changed 13 years ago by fingolfin

If this doesn't work with the original game, then it's not a bug in ScummVM.
Hence i am moving this to feature requests.

Is this really an official version of Monkey Island? This sounds unlikeyl... are you
sure it's not a fan made / hacked version ?

comment:3 Changed 13 years ago by SF/gourry

Yeah, it is the official version... I played with it for
years since 1991 christmas... It was on four 3,5" 720Kb
disks... well something wrong happened to those disks (me
and my father were not good at the times with the PC) but
I was able to back it up on two 3,5" 1.44Mb floppy! Anyway
it NEVER showed vowels with stress, I thought that as
english keyboard haven't them, translators simply avoid to
put them. But after I saw that scummvm showed "é" letter
wich was not showed in DOS version either (as I remember)
I opened scripts with ScummEX and found that mapping that
I enumerated earlier. If it can help this is md5sum of my
files:
477dbafbd66a53c98416dc01aef019ad *000.lfl
280f20d081cc7701c38dfdc8b701c58c *901.lfl
13a9297cca1b33c4ef9c24ed1dacc64d *902.lfl
6c72dd66cccae6308f962075c314ee16 *903.lfl
6c99003057f3b84d9fedf7a88dba813b *904.lfl
f30f83fb4d684ee9a07be738772c1ba2 *Disk01.lec
4870a44c5f73f2bc9ad49c59b71e4a0b *Disk02.lec
9fb63686014ef1cffe08a31297daba78 *Disk03.lec
95cafe5c01a873b432579923424b7790 *Disk04.lec

comment:4 Changed 13 years ago by fingolfin

Well the most likely cause for the problem then is that the wrong font was
included in the data files. If that is the case, there is nothing we can do about
the issue short of adding a new font.

WIthout having (legal!) access to this version of MI EGA, it'll be hard to
impossible to do something about this issue, I am afraid... :-/

comment:5 Changed 13 years ago by SF/gourry

I thought that fonts were hard coded inside ScummVM
executables and I always thought that every Italian EGA
Monkey1 version had the same problem... So if you can
provide me some kind of hint (or piece of documentation) I
will look after this issue by myself. I'm quite a skilled
programmer (expecially Java and C, but I know C++ basics).
Maybe I could provide some sort of patch for everybody
that have this version of Monkey1...

comment:6 Changed 13 years ago by fingolfin

No, the fonts are not encoded in the executable, neither in MONKEY.EXE nor in
ScummVM.

Rather, they are in the files 901.LFL, 902.LFL etc. in the case of MonkeyEGA.

comment:7 Changed 12 years ago by fingolfin

Priority: normallow

comment:8 Changed 12 years ago by fingolfin

Summary: MI1 EGA Italian Floppy missing vowelsSCUMM: MI1 EGA Italian Floppy missing vowels

comment:9 Changed 5 years ago by digitall

Component: Engine: SCUMM

comment:10 Changed 5 years ago by SF/gourry

Hi,
I just got a notification about this RFE because of edit operation. I think that it can be closed. I don't find any button to close it.

Thanks,
Marco

comment:11 Changed 5 years ago by digitall

Thanks. Closing.

comment:12 Changed 5 years ago by digitall

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.