Opened 16 years ago

Closed 15 years ago

Last modified 13 months ago

#7371 closed enhancement (wontfix)

text speed should not be limited to 90

Reported by: SF/bomm Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

When changing text speed with + and - keys it is not possible to make it as slow as I want.
It is possible to select a very slow speed with the talkspeed keyword in the config file, but when I accidentally hit the - key, the speed will be set to the slowest value I can select with the keys.

I think the following code in scumm/scummvm.cpp is responsble for this:

} else if (_lastKeyHit == '-') { // - text speed down
_defaultTalkDelay += 5;
if (_defaultTalkDelay > 90)
_defaultTalkDelay = 90;

I would like to have a much higher limit as I used values 200 or 300 in the config files for children who need much time for reading because they just learned to read.

A useful limit could be 500 or 1000.

A new key in the config file, e.g. maxtalkspeed=500, with the current limit of 90 as default value would be nice.

Bodo

Ticket imported from: #952723. Ticket imported from: feature-requests/187.

Change History (5)

comment:1 by fingolfin, 16 years ago

This is a feature request, not a bug report -> moving to the appropriate
tracker.

Also: IMO we should not make things more confusing by adding a config
key for this; either we change the limit, or we don't...

comment:2 by fingolfin, 16 years ago

Component: --Unset--

comment:3 by Kirben, 15 years ago

Owner: set to Kirben
Resolution: wontfix
Status: newclosed

comment:4 by Kirben, 15 years ago

Increasing the limit could cause possible timing issues, so it
will not be changed.

comment:5 by digitall, 13 months ago

Component: Engine: SCUMM
Note: See TracTickets for help on using tickets.