Opened 17 years ago

Closed 15 years ago

Last modified 15 years ago

#719 closed defect (fixed)

FT: German ß (ß) is too high

Reported by: SF/lexlechz Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

If subtitles are containing the german ß-character
displayed lines are too high.
This causes visual side-effects if the text is displayed to
handle user-choices. E.g. in the german version of "Full
Throttle" ("Vollgas") multiple choices are presented
(initial bar-sceene and/or 1st meeting with Maurene).
Highlighting the (too high) line will erase parts of other
choices - which are redrawn after they are highlighted.

Cosmetical problem, but should be fixed easily ;-)

Ticket imported from: #705221. Ticket imported from: bugs/719.

Attachments (6)

ft.s01 (40.0 KB ) - added by SF/lexlechz 17 years ago.
VollgasLucasArts.JPG (86.9 KB ) - added by SF/lexlechz 17 years ago.
Original LucasArts renderer
VollgasSummVM.JPG (64.4 KB ) - added by SF/lexlechz 17 years ago.
Vollgas.JPG (69.7 KB ) - added by SF/lexlechz 15 years ago.
Test with SCUMMVM in August 2004
Vollgas2.JPG (68.9 KB ) - added by SF/lexlechz 15 years ago.
Nightly update 2004/Aug/09
Vollgas3.JPG (66.2 KB ) - added by SF/lexlechz 15 years ago.
Nightly update 2004/Sept/05

Download all attachments as: .zip

Change History (40)

comment:1 by fingolfin, 17 years ago

Would you please read the instructions on the bug submission page? https://sourceforge.net/tracker/?func=add&group_id=37116&atid=418820

Once done, follow the guidelines there and add the missing information, please ...

by SF/lexlechz, 17 years ago

Attachment: ft.s01 added

comment:2 by SF/lexlechz, 17 years ago

ScummVM 0.3.0b,
Savegame for German version of Full Throttle ("Vollgas")
attached as FT.S01. After loading you'll immediately stay in
one of the 'scrambled' menus. Move between selections to
see the effect.

comment:3 by SF/lexlechz, 17 years ago

Game: talking version,
Platform: WIN32
Problem can be re-created always (at least with the save-
game from a german PC).
Don't know where the character set is stored. Within scumm
(more likely) or the game-image?

comment:4 by fingolfin, 17 years ago

The fonts are part of the game data.

Anyway, would you please verify whether this problem still occurs with latest CVS? Daily builds are available from our web site.

comment:5 by fingolfin, 17 years ago

Component: --Unset--Engine: SCUMM
Game: Full Throttle
Summary: German ß (ß) is too highFT: German ß (ß) is too high

by SF/lexlechz, 17 years ago

Attachment: VollgasLucasArts.JPG added

Original LucasArts renderer

comment:6 by SF/lexlechz, 17 years ago

Tested with newest build, the problem still persists.
Compared with original game and found more precise details:
a) the font is the same (so the is too high in the original
game too)
b) the original renderer draws characters using a transparent
background. An example from the original game to be more
precisely:
+ selection with 4 lines/choices
+ lines 3 and 4 have too high characters
+ selection 3 is highlighted
+ line 1 is ok
+ line 2 is overlapped by highlighted characters of line 3
+ line 3 is overlapped by non-highlighted characters of line 4
+ line 4 is ok
Where the original Scumm engine draws overlapping
characters by using transparent backgrund the ScummVM
seems 1st to erase the background before the text is drawn.
If characters are too high this behavior causes text-parts of
the previous line to be erased.
I'll attach 2 snapshots for better comparison:
+ VollgasLucasArts.JPG (original version)
+ VollgasSummVM.JPG (current ScummVM)

by SF/lexlechz, 17 years ago

Attachment: VollgasSummVM.JPG added

comment:7 by fingolfin, 17 years ago

Pawel, any idea on this?

comment:8 by fingolfin, 17 years ago

Owner: set to aquadran

comment:9 by fingolfin, 17 years ago

Looking at this, I believe it's the same problem that causes drawin glitches in COMI: Namely the background of the verbs is erased, when it shouldn't be. This causes in COMI in the canon room the room background be visible even though the text is over the canon. I.e. behind the verb text, you can see through the canon.
I once had a fix in CVS which had to be reverted since it caused troubles in other games. I need to look into that, maybe it can be reapplied but restricted to FT/COMI

comment:10 by fingolfin, 17 years ago

Owner: aquadran removed

comment:11 by fingolfin, 17 years ago

I just checked in a patch for the COMI verb drawing. I wonder if it has any effect on Full Throttle... Maybe you could test this with latest CVS? Of course it'll be up to 24 hours till my change is in the daily builds.

comment:12 by SF/lexlechz, 17 years ago

Re-tested with CVS-build from 30th of march, but the
problem persists.
Note: maybe it's not a good idea to restrict the fix to FT and
COMM only. I think german titles will have this problem in
general. At least, it may depend on the defined in-game
character-set.

comment:13 by fingolfin, 17 years ago

The patch is not "restricted" to FT and COMI, it's simply so that they are the only Scumm games to use the "free flow" style of verbs. All other games handle verbs differently.

comment:14 by fingolfin, 17 years ago

What is the status of this item?

comment:15 by SF/lexlechz, 17 years ago

Retested with scummvm-0.4.1-win32 (release) and nightly
build from 2nd of June 2003. Unfortunately the problem is not
fixed here. Looks like as on the date I've reported the
problem...

comment:16 by SF/lexlechz, 17 years ago

Retested with scummvm-0.4.1-win32 (release) and nightly
build from 2nd of June 2003. Unfortunately the problem is not
fixed here. Looks like as on the date I've reported the
problem...

comment:17 by SF/lexlechz, 17 years ago

Retested with scummvm-0.4.1-win32 (release) and nightly
build from 2nd of June 2003. Unfortunately the problem is not
fixed here. Looks like as on the date I've reported the
problem...

comment:18 by SF/lexlechz, 17 years ago

Retested with scummvm-0.4.1-win32 (release) and nightly
build from 2nd of June 2003. Unfortunately the problem is not
fixed here. Looks like as on the date I've reported the
problem...

comment:19 by SF/lexlechz, 17 years ago

Retested with scummvm-0.4.1-win32 (release) and nightly
build from 2nd of June 2003. Unfortunately the problem is not
fixed here. Looks like as on the date I've reported the
problem...

comment:20 by SF/lexlechz, 17 years ago

Retested with scummvm-0.4.1-win32 (release) and nightly
build from 2nd of June 2003. Unfortunately the problem is not
fixed here. Looks like as on the date I've reported the
problem...

comment:21 by fingolfin, 16 years ago

Summary: FT: German ß (ß) is too highFT: German ß (ß) is too high

comment:22 by Kirben, 15 years ago

Does this problem still occur when using recent ScummVM
CVS version ? the way verbs are handled for Full Throttle was
changed recently.

comment:23 by fingolfin, 15 years ago

Status: newpending

comment:24 by fingolfin, 15 years ago

lexlechz, can you tell us whether the problem still occurs with latest CVS
?

comment:25 by SF/lexlechz, 15 years ago

Retest with SCUMMVM CVS-build 'August 9, 2004, 3:53 am'
shows a more stable - but still incorrect - behavior.
Text-Rendering seems now to be performed bottom-up, so
that the upper line always overwrites possible contents of
the prior (lower) line. This is regardless if a line is highlighted
or not. See the attached screenshot "Vollgas.JPG" for more
information.
From my point of view the handling is improved and more
consistent. But the hilighted text need to be drawn as last,
which should fix the problem finally.

comment:26 by SF/lexlechz, 15 years ago

Status: pendingnew

by SF/lexlechz, 15 years ago

Attachment: Vollgas.JPG added

Test with SCUMMVM in August 2004

comment:27 by Kirben, 15 years ago

Try current Windows snapshot and see if it helps at all.
The original Full Throttle drew verbs in the opposite order, I
just changed ScummVM to act the same way.

by SF/lexlechz, 15 years ago

Attachment: Vollgas2.JPG added

Nightly update 2004/Aug/09

comment:28 by SF/lexlechz, 15 years ago

The problem is now more worse. The prior drawing order
seemed to be ok, but was in fact reverse, so the change
corrected the processing but garbles the screen-texts.
Compare the screenshot of:
- this nightly build: Vollgas2.jpg
with changed drawing order
- the prior nightly build: Vollgas.jpg
with old drawing order
- the original SCUMM: VollgasLucasArts.jpg
as drawn in the real SCUMM-engine
VollgasLucasArts.jpg is shows that the text is drawn as
following:
- from top to bottom:
oversized characters in lower lines are overwriting
characters in upper lines
- with transparent character background:
Vollgas2.jpg (new nightly build) shows erased characters
in the above lines. This is caused by too large characters
in the lower lines. Text is supposed to be drawn with
transparent (opaque) background rather than using
the gamescreen background.

comment:29 by fingolfin, 15 years ago

Priority: normallow

by SF/lexlechz, 15 years ago

Attachment: Vollgas3.JPG added

Nightly update 2004/Sept/05

comment:30 by SF/lexlechz, 15 years ago

Attached new snapshot of the nightly build (Vollgas3.JPG)
2004/Sept./05. Seems to be better, but still not ok.

comment:31 by fingolfin, 15 years ago

I just recently acquired a copy of the german FT version for macintosh, so
I can now reproduce the issue myself, which means I should be able to
take a look at it (once I have some spare time, that is... ;-)

comment:32 by fingolfin, 15 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:33 by fingolfin, 15 years ago

Fixing this in latest CVS turned out to be a trivial matter of reversing the
verb drawing order. It now actually matches disasm, and the new drawing
order is also the same as was used in MI/MI2. According to the CVS logs
of verbs.cpp, the order was changed back and forth a couple times. Bad
bad bad :-/

comment:34 by Kirben, 15 years ago

I reversed the verbs order earlier (See my last comment) but it
made the situation worse last time, which was why it was
reverted. So another change in the meantime must have
helped.

Note: See TracTickets for help on using tickets.