Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#7162 closed defect (fixed)

On some levels parts of screen are black, goblins become invisible.

Reported by: SF/riddleman Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliiins

Description

On some levels parts of screen are black, goblins become invisible.
1)the bug is not already known.
2)the latest Subversion/daily build - bug has place
Version of daily build:
ScummVM 1.9.0git2713-g246d48b (Jul 15 2016 23:44:5)
Features compiled in: TAINTED Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora
AAC FreeType2 JPEG PNG
3)a)ScummVM version (scummvm -v)
ScummVM 1.8.1 (May 22 2016 15:57:02)
Features compiled in: Vorbis FLAC MP3 RGB zLib MPEG2 FluidSynth Theora AAC
FreeType2 JPEG PNG
b) Some parts of screen are black on levels 03,09,16; on level 20 goblins are
invisible:
Appearence on levels:
Level: Code: Console message:
Level 03 ICIGCAA WARNING: Failed to load EXT resource (avt002.tot, 9/11, 3)!
Level 09 ICVGCGT WARNING: Failed to load EXT resource (avt009.tot, 6/8, 3)!
Level 16 TCVQRPM WARNING: Failed to load EXT resource (avt016.tot, 5/10, 3)!
Level 20 NNGWTTO WARNING: Failed to load EXT resource (avt020.tot, 0/9, 3)!
c)Language of game/Version of game (EGA/DOS,EGA/DOS/Russian)
e)Platform and Compiler - Win32
f)the last version without the bug - 1.2.1
the first version including the bug - 1.3.0
Pictures are included in GOB1 Errors Pics.zip

Ticket imported from: bugs/7162.

Attachments (1)

GOB1 Errors Pics.zip (1.0 MB ) - added by SF/riddleman 3 years ago.

Download all attachments as: .zip

Change History (5)

by SF/riddleman, 3 years ago

Attachment: GOB1 Errors Pics.zip added

comment:1 by DrMcCoy, 3 years ago

Owner: set to DrMcCoy

comment:2 by DrMcCoy, 3 years ago

Okay, I can reproduce that here. But only in the EGA version; the VGA version is unaffected.

It seems to be related to resource-loading. I did a rewrite of the TOT/EXT loading some time back, could be around 1.3.0. Possibly the cause. I'll look into it.

comment:3 by DrMcCoy, 3 years ago

Resolution: fixed
Status: newclosed

comment:4 by DrMcCoy, 3 years ago

Okay, I found the issue: the problem is that some resource sizes are wrong in the resource table of the data files in the EGA version of Gobliiins. The original happy reads past the resource structure and before 1.3.0, we did as well. In 1.3.0, I stopped that, though, and made the game throw a warning instead, leading to the resource not being loaded at all.

There was already a workaround for this exact issue present, because Little Red Riding Hood also has a broken resource size somewhere. So I just enabled that workaround for Gobliiins EGA too.

So the issues should be fixed with commit aca13f7ba95f0707d6d68fb52bfa36b1d420a42c or the new daily build.

Thank you for reporting! :)

Note: See TracTickets for help on using tickets.