Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7160 closed defect (invalid)

ANDROID: COMI speech doesn't work after 1.6 to 1.8 upgrade

Reported by: SF/cavey Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I've been playing COMI on ScummVM 1.6 under Android Lollipop (CyanogenMod) on a Galaxy S2 for a while, and a few weeks back the apps store prompted me to upgrade to the latest ScummVM 1.8.

Since the upgrade, the game loads and plays but the speech no longer works; despite the game settings being set to "Speech" the game always uses subtitles but at maximum speed which makes it almost impossible to play.

According to the Game settings, the version I am playing is:

id: comi Name: The Curse of Monkey Island (Windows/English) Language: English Platform: Windows

Many thanks,

Mark.

Ticket imported from: bugs/7160.

Attachments (3)

scummvm.log (546 bytes ) - added by SF/cavey 4 years ago.
scummvm.ini (328 bytes ) - added by SF/cavey 4 years ago.
scummvm.log.gz (10.6 KB ) - added by SF/cavey 4 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 by sev-, 4 years ago

Is it original or repacked version? Could you please enlist the game files? E.g. 'ls -lR' or 'dir /w /s'

comment:2 by SF/cavey, 4 years ago

It's from "The Monkey Island Bounty Pack":

$ ls -lR .: total 149296 -rw-r--r-- 1 mca mca 76791 Oct 15 1997 comi.la0 -rw-r--r-- 1 mca mca 69340645 Oct 15 1997 comi.la1 -rw-r--r-- 1 mca mca 83452557 Oct 15 1997 comi.la2 drwxr-xr-x 2 mca mca 4096 Jul 3 2014 resource

./resource: total 887652 -rw-r--r-- 1 mca mca 14973880 Oct 7 1997 bbsan.san -rw-r--r-- 1 mca mca 20817514 Oct 8 1997 curserng.san -rw-r--r-- 1 mca mca 435640 Sep 30 1997 fg010gp.san -rw-r--r-- 1 mca mca 10945770 Oct 7 1997 finale.san -rw-r--r-- 1 mca mca 94240 Oct 2 1997 font0.nut -rw-r--r-- 1 mca mca 104848 Aug 13 1997 font1.nut -rw-r--r-- 1 mca mca 104848 Aug 13 1997 font2.nut -rw-r--r-- 1 mca mca 60968 Aug 14 1997 font3.nut -rw-r--r-- 1 mca mca 126954 Sep 16 1997 font4.nut -rw-r--r-- 1 mca mca 1079072 Sep 19 1997 kis030.san -rw-r--r-- 1 mca mca 439080 Oct 10 1997 language.tab -rw-r--r-- 1 mca mca 14072824 Oct 7 1997 lavaride.san -rw-r--r-- 1 mca mca 7029446 Oct 7 1997 liftcrse.san -rw-r--r-- 1 mca mca 9848862 Oct 7 1997 moreslaw.san -rw-r--r-- 1 mca mca 176849464 Oct 3 1997 musdisk1.bun -rw-r--r-- 1 mca mca 190295532 Oct 3 1997 musdisk2.bun -rw-r--r-- 1 mca mca 11075238 Oct 7 1997 newboots.san -rw-r--r-- 1 mca mca 82864970 Oct 9 1997 opening.san -rw-r--r-- 1 mca mca 773474 Sep 18 1997 sb010.san -rw-r--r-- 1 mca mca 768550 Sep 19 1997 sb020.san -rw-r--r-- 1 mca mca 10347350 Oct 7 1997 sinkshp.san -rw-r--r-- 1 mca mca 150287970 Sep 23 1997 voxdisk1.bun -rw-r--r-- 1 mca mca 189733340 Sep 23 1997 voxdisk2.bun -rw-r--r-- 1 mca mca 15003404 Oct 7 1997 wrecksan.san -rw-r--r-- 1 mca mca 768114 Sep 20 1997 zap010.san

comment:3 by sev-, 4 years ago

Hmmm. Could you please also provide contents of the following file:

Android/data/org.scummvm.sdl/files/.cache/scummvm/logs/scummvm.log

Please make sure it tells something like Starting 'The Curse of Monkey Island'.

by SF/cavey, 4 years ago

Attachment: scummvm.log added

comment:4 by SF/cavey, 4 years ago

Here it is. It doesn't seem to have the "Starting..." message included though?

comment:5 by sev-, 4 years ago

Err, no. The thing is that this file gets overwritten on every ScummVM restart, and it looks that you launched it without running COMI. Could you please start ScummVM SDL, then start COMI, skip the intro and click on some object, so speech is supposed to be played. Then send the resulting scummvm.log

comment:6 by SF/cavey, 4 years ago

I've just tried again and that's all that I see in the file, except that the timestamps update themselves?

comment:7 by sev-, 4 years ago

OK, another attempt (the thing is that we cannot reproduce the bug here):

  1. Open file Android/data/org.scummvm.sdl/files/.config/scummvm/scummvm.ini
  2. In the first section [scummvm] add on a separate line, right after '[scummvm]': debugLevel=5
  3. Run COMI, skip to the first scene, wait for 'Blast ye scurvy dogs!'
  4. Attach scummvm.log

comment:8 by sev-, 4 years ago

Don't forget to remove the line after testing, as it is quite noisy.

comment:9 by sev-, 4 years ago

Ah, and also please attach the mentioned scummvm.ini as a whole (particularly sections [scumm] and [comi] are of interest).

by SF/cavey, 4 years ago

Attachment: scummvm.log.gz added

comment:10 by SF/cavey, 4 years ago

Okay that looks better - here they are.

comment:11 by sev-, 4 years ago

Thanks. As you see, it has difficulties with reading your voice bundles:

BundleMgr::decompressSampleByName() Failed finding sound CNGT004.IMX

Could you please provide md5 sum of your files voxdisk1.bun and voxdisk2.bun?

Here are the references:

MD5 (VOXDISK1.BUN) = c25c4a1a0ebdcfa50f4027541b096326 MD5 (VOXDISK2.BUN) = b47a3d4452d64e2283c7982c0726d81b

comment:12 by SF/cavey, 4 years ago

Oh now this is interesting:

15649856f32c162538745cf4094ade55 voxdisk1.bun ee1e9b7f1b2a91548cdc36d6137ab883 voxdisk2.bun

Let me go double-check against the originals on my PC.

comment:13 by SF/cavey, 4 years ago

On the PC I have the below:

c25c4a1a0ebdcfa50f4027541b096326 voxdisk1.bun ee1e9b7f1b2a91548cdc36d6137ab883 voxdisk2.bun

I've just copied voxdisk1.bun back over onto the phone and it seems to be working again!

comment:14 by sev-, 4 years ago

Owner: set to sev-
Resolution: invalid
Status: newclosed
Summary: COMI speech doesn't work after 1.6 to 1.8 upgradeANDROID: COMI speech doesn't work after 1.6 to 1.8 upgrade

comment:15 by sev-, 4 years ago

Great, thanks for checking. Closing the bugreport as invalid.

comment:16 by SF/cavey, 4 years ago

Indeed, checked again and it's all fine - thanks for taking the time to look into this. Just a thought - if you know the hashes of the files for all game variants, would it be possible to have a "Verify" feature in the game menu that provides a warning if the hashes don't match an inbuilt list? Or does this really happen so rarely in bug reports that it's not worth the bother?

Note: See TracTickets for help on using tickets.