Opened 3 years ago

Closed 3 years ago

#7154 closed defect (fixed)

SCI: LB1: Exiting arm-oiling cut scene skips death, breaks typing

Reported by: SF/boneosaurusrex Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: original script Cc:
Game: Laura Bow 1: The Colonel's Bequest

Description

Oiling the axe-holding arm of the armor is supposed to kill Laura as the axe drops and slices her in half. The "oil arm" / "oil axe" command triggers a cut scene showing a close-up of the armor being oiled, and then returns to the normal view and the axe is dropped.

The cut scene displays the text "Press 'E' to Exit". The bug is that if do you press 'E' (before the cut scene automatically ends) the game returns to the normal view and the axe is not dropped and the player resumes control instead of being dead. Typing any letter no longer brings up the command window so commands can't be entered. F3 (enter last command) also doesn't do anything. Typing works again once another room is entered.

This is a bug in the original game. It occurs in the dos version under dosbox and ScummVM. I found this bug while testing the fix for #7119 and confirmed that it occurs before and after that fix. Amiga and Atari versions behave differently; the axe still doesn't drop but typing still works. I briefly compared the decompiled room scripts and Sierra added a call to User:canControl(1) in the room script. It seems like the better behavior would be for the axe to fall as intended.

Attached is a savegame from the dos version from the latest ScummVM nightly build. Type "oil arm", press E at the cut scene, then try to type a command.

Ticket imported from: bugs/7154.

Attachments (1)

laurabow.021 (26.3 KB ) - added by SF/boneosaurusrex 3 years ago.

Download all attachments as: .zip

Change History (7)

by SF/boneosaurusrex, 3 years ago

Attachment: laurabow.021 added

comment:1 by m-kiewitz, 3 years ago

For me the axe does not fall in the DOS version, when I press "E".

Nevermind, it doesn't fall at all unless it kills Laura.

comment:2 by m-kiewitz, 3 years ago

Fixed this with a script patch in commit 9f78903

comment:3 by m-kiewitz, 3 years ago

Component: Engine: SCI
Game: Laura Bow 1: The Colonel's Bequest
Keywords: original script added
Owner: set to m-kiewitz
Resolution: fixed
Status: newpending

comment:4 by SF/boneosaurusrex, 3 years ago

This fixes it, thanks!

comment:5 by m-kiewitz, 3 years ago

Thank you for your feedback.

comment:6 by m-kiewitz, 3 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.