Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#7141 closed defect (fixed)

DOTT: Graphical glitches while loading savedgame when stereo is running

Reported by: BenCastricum Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

On ScummVM v1.9.0 (git) in DOTT the screen goes op and down if you turn on the stereo in green tentacles room. After loading a savegame while this is happening the bouncing is turned of but the offset of the screen is not reset. The can case part of the screen to be chopped of. When the screen is at one of the lowest offsets, the cursor starts leaving trails (see screenshot).

Trailing cursors also happen in normal gameplay when stereo is on, but less noticable due to screen refreshes. So it's actually 2 "bugs".

Ticket imported from: bugs/7141.

Attachments (3)

SXSWDN~3.PNG (53.6 KB ) - added by BenCastricum 3 years ago.
tentacle.s02 (26.3 KB ) - added by BenCastricum 3 years ago.
tentacle.s03 (28.1 KB ) - added by BenCastricum 3 years ago.

Download all attachments as: .zip

Change History (6)

by BenCastricum, 3 years ago

Attachment: SXSWDN~3.PNG added

by BenCastricum, 3 years ago

Attachment: tentacle.s03 added

comment:1 by BenCastricum, 3 years ago

A saved game from Linux version where stereo is on is s03. S02 is just a random savegame where stereo is off. Start 3 and try to load game S02 while the screen is at its lowest.

comment:2 by BenCastricum, 3 years ago

I managed to track down the cause of both issues, and opened a pull request containing the fixes.

comment:3 by sev-, 3 years ago

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:4 by sev-, 3 years ago

The pull request was accepted, thus the bug is fixed.

Note: See TracTickets for help on using tickets.